UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
1,480 Views
Registered: ‎02-27-2016

Named port connection 'm_axis_video_TVALID' does not exist

I am working on a video pipeline design and want to use the video test pattern generator (v_tpg).  In a test project I select the v_tpg IP from the IP catalog, configure it, and then let it generate the outputs.  The out-of-context synthesis for the IP fails with a serious of errors like the following:

 

ERROR: [Synth 8-448] named port connection 'm_axis_video_TVALID' does not exist for instance 'inst' of module 'v_tpg_0_v_tpg' [d:/Work/prj_ip_test/prj_ip_test.srcs/sources_1/ip/v_tpg_0/synth/v_tpg_0.v:205]

 

I then created an example design for the v_tpg IP using the "Open Example Design..." option.  Run synthesis on the example project yields the same sort of failures.

 

The v_tpg is configured for 2 samples per clock, 12 bit data width, and a maximum frame size of 4096 x 3072.

 

I am currently running Vivado/HLS 2017.3.

 

Any ideas why I am getting this error, even on the example design?

DornerWorks
https://goo.gl/8wtknW
0 Kudos
3 Replies
Moderator
Moderator
1,415 Views
Registered: ‎10-04-2017

Re: Named port connection 'm_axis_video_TVALID' does not exist

Hi @corrin.meyer,

 

Using the steps listed in PG103, I can successfully synth/implement/generate a bitstream for the example design using Vivado 2017.3.

 

Based on the error you are seeing it looks like the encrypted source file is not being called properly. On Windows-based operating systems the recommendation is to make your working directory path as short as possible to work around the Windows 260 character limit.

 

If you are on windows can you re-try from "D:\X\"?
If you are on Linux, can you post your log so that we can take a better look at the issue?

 

Regards,
Sam

 

Don't forget to reply, kudo, and accept as solution.

Xilinx Video Design Hub
vtpg_xcf.png
Summary.png
Moderator
Moderator
1,403 Views
Registered: ‎11-09-2015

Re: Named port connection 'm_axis_video_TVALID' does not exist

Hi @corrin.meyer,

 

This is a known issue of the TPG (related to the HLS compiler) which only happen on Windows machine. It is under investigation with development.

 

Sometimes changing the configuration for sample per clock or bit per pixel can work.

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
Moderator
Moderator
1,178 Views
Registered: ‎11-09-2015

Re: Named port connection 'm_axis_video_TVALID' does not exist

Hi @corrin.meyer,

 

The patch for windows to fix this issue is available in AR#70445 .

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos