UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer garryc3
Observer
2,637 Views
Registered: ‎11-20-2017

No video out of AXI stream to video out IP

I have create a subsystem with a video being input using HDMI which is then converted to AXI steam using the video in to AXI stream IP. I then use the video timing block to generate the timing for the AXI stream to video out IP and the data stream for this comes straight from video in to AXI stream IP, the video is finally output using VGA.

 

My issue is I'm not seeing any video out of the VGA when I connect the system like this, it works fine when I connect the video out from the HDMI directly to the video in of the VGA. I piped the locked signal of the AXI stream to video out and it never gets asserted, I think my issue may be with the video timing block. I want to us the AXI stream to video out IP in slave mode where the video timing block is detects the video timing from the video in to AXI stream and generates the timing for the AXI stream to video out.

 

I have a attached two pictures one of the subsystem and one of the features I am using in the timing block. Can someone tell me if I am using the features for the mode I want to use or if there is something else I might be doing wrong?

image.png.f48e8402e9d47271e063ffb4cbb3c8ad.png
VTC_parameters.JPG
0 Kudos
21 Replies
Scholar watari
Scholar
2,602 Views
Registered: ‎06-16-2013

Re: No video out of AXI stream to video out IP

Hi @garryc3

 

Did you describe C source code for control these IPs ?

If no, you need to prepare control code for these IPs.

 

Best regards,

 

0 Kudos
Moderator
Moderator
2,590 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

@garryc3,

 

1. Are you getting the lock signal from the AXI4-Stream to video out?

2. If not, is the underflow output high? If yes, check why you do not have enough data coming in

3. If not, make sure the size from you input and the size configured in your VTC generator match

 

 @watari,

 

There is no need for C code as they do not have the AXI4-Lite interface enabled.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Highlighted
Observer garryc3
Observer
2,589 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

I didn't think I needed C code to control this IP? I have removed the AXI lite interface from the IP so I assumed the video timing detection and generation would work automatically, is this now the case?

0 Kudos
Moderator
Moderator
2,553 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

Did you see my reply on this? Does it help?

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
2,545 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

Yes I did see your reply and here is my response to your questions

- No the lock signal from the axis to video out IP is not set

- Yes the underflow signal is being asserted for axis to video out IP

- Yes there is data flowing into axis to video out IP from the video in to axis IP(shown in  the image)

 

I think the format setting in the VTC and it is set to 720p which is the video format I am using in the Diligent dvi2rgb IP. I assume setting the VTC to 720p should be enough to ensure they match?

 

Regards,

 

Cathal

videoIn2axis_output.JPG
0 Kudos
Moderator
Moderator
2,540 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

If the underflow signal is high, it might be that your input data stream is not fast enough for you output video.

 

You might want to try adding a VDMA or a FIFO before the AXI4-Stream to video out. It might help.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
2,495 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

I tried inserting a AXI stream data FIFO before the video out but I'm still getting an underflow issue. Can the VDMA be setup to automatically stream data through it or does it need a driver? Do you have any examples applications that use the VDMA like this?

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
2,479 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

The VDMA needs some configuration (Hstride/Hsize and Vsize). There is an example design for the VDMA (refer to its product guide).

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
Scholar watari
Scholar
2,476 Views
Registered: ‎06-16-2013

Re: No video out of AXI stream to video out IP

Hi @garryc3

 

If you already set some parameters by software or something on VDMA and the result is same as before, I suggest to fix floating port at "AXI4Stream to Video Out" module.

 

Would you try it ?

 

Best regards,

 

0 Kudos
Observer garryc3
Observer
2,316 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

From looking at the VDMA spec it looks like you need some form of a driver to pass AXI stream data through the block. Is there anyway to use this block without a driver?

 

On the fix floating port comment, I'm not sure what you are asking here? Are you suggesting to leave the AXI stream to video out port hanging? If so what would this achieve?

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
2,307 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3

 

From looking at the VDMA spec it looks like you need some form of a driver to pass AXI stream data through the block. Is there anyway to use this block without a driver?

> You need to configure the register. I highly recommend you to use the drivers or a processor configuring the registers directly. However you should be able to do your own IP to do the AXI transactions

 

On the fix floating port comment, I'm not sure what you are asking here? Are you suggesting to leave the AXI stream to video out port hanging? If so what would this achieve?

> This comment is from @watari. I think from his experience, making sure that all the port are connected to a known value (i.e. no floating point) can solve the issue.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Moderator
Moderator
2,259 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

HI @garryc3,

 

Do you still have issues? If it is solved, could you kindly mark a reply as accepted solution to close the topic?

 

If not, you might want to have a look to my latest Video Beginner Series 8: Debugging the AXI4-Stream to Video Out IP. This could help you understand why it is not working.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
2,249 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Yes I'm still having the issue as I can't manage to get the VDMA to work while trying to stream it. Am I correct in assuming a AXI streaming FIFO should work just as well as a VDMA?

 

Ok I'll have a look at this blog.

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
2,247 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

Yes you should be fine with an AXI4-Stream FIFO


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
2,183 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

Unfortunately due to the lack of logic on the zybo platform I can't view the debug bus on the AXI stream to RGB. I'm trying to switch to the pynq platform now since this has more logic but unless you have any other suggestion I don't think I can debug this any further.

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
2,181 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

You can try to remove some part of your design for now.

Or you can try in simulation.


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Moderator
Moderator
2,087 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

HI @garryc3,

 

Do you have any updates on this? Did you fix your issue?

 

Thanks,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
1,987 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

No sorry I haven't had a chance yet, I'll update this once I get a chance to debug it further.

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
1,750 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

HI @garryc3,

 

Do you have any updates on this? Is it working now?

 

If your question is answered or your issue is solved, please kindly mark the response which helped as solution (click on "Accept as solution" buton below the reply)

If this is not solved/answered, please reply in the topic giving more information on your current status.

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Observer garryc3
Observer
1,418 Views
Registered: ‎11-20-2017

Re: No video out of AXI stream to video out IP

Hi Florent,

 

Sorry for the delay in my response. No I was able to get this working and I had to use a different solution for my project in order to overcome this. My project is finishing up now so I'm not sure what to do with this ticket? Any suggestion, should it just be left open?

 

 

Thanks,

 

Cathal

0 Kudos
Moderator
Moderator
1,404 Views
Registered: ‎11-09-2015

Re: No video out of AXI stream to video out IP

Hi @garryc3,

 

Thanks for the update.

 

As this is not solved, you can leave it. You can come back to this if you are faced to this issue again.

 

Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos