UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
2,008 Views
Registered: ‎04-14-2017

VDMA writing frames problem

Hi,

i downloaded this tutorial :       "Adam Taylor’s MicroZed Chronicles, Part 119: VDMA software"

 and tryed to test it , i fllowed exactly what is mentionned in the tuto but it doesn't  work, the problem  is that the VDMA doesn't write the fames in the memory,

 

1.png

How can i resolve this problem please, is there something to verify.

 

Tags (2)
0 Kudos
3 Replies
Moderator
Moderator
2,007 Views
Registered: ‎11-09-2015

Re: VDMA writing frames problem

Hi @mkooli,

 

the VDMA doesn't write the fames in the memory

-> what did you use to monitor that? How do you know that it is not writting in the memory? Do you have an error message in the UART console?

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Adventurer
Adventurer
1,997 Views
Registered: ‎04-14-2017

Re: VDMA writing frames problem

as it 'showed in the screen shot ; transfer of frames failed    also i tried to see the output of the test pattern generator  "m_axis_video"

using the chipscope, i have a video stream  but when i see the output of the VDMA    "M_AXIS_MM2S"  i have no thing (0000) ,  this is the problem

 

0 Kudos
Visitor mohamed34
Visitor
497 Views
Registered: ‎05-12-2018

Re: VDMA writing frames problem

Hi there,

 

Someone resolved the probleme with this tutorial?

0 Kudos