We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Observer jackf
Registered: ‎08-02-2018

Video mixer scale problem after upgrading from v2.0 to v3.0


Recently I worked on xilinx video mixer for osd development, my dev board is ZCU102, everything worked well in vivado & sdk 2017.4, the video mixer IP in 2017.4 is version 2.0. 

But after upgrading the project to 2018.3 (both vivado and sdk), the video mixer IP also upgraded to version 3.0, and I found that if we enable the memory layer scaling, the output seemed like "grid". Without using scaling everything is OK. As shown below, I filled one memory layer with pure white, color format is RGBA8 so I write 0xffffffff in the memory.

The first one is scale 1x (no scale), I can see the expected whole white layer; The second picture is scale by 4x, I can see the layer is not expected white layer but like a "grid", look closer I found out seems like every 1 pixel it will have a very low alpha pixel. I did multiple tests, like write another color into the even memory address, without the scaling the output is as expected but after scaling no matter 2x or 4x it will lost all the even memory color. But seems they do not totally disappear, only got very low alpha value cause I can see some faint color every 2 vertical lines.

IMG_0896(1).JPGno scale, everything ok


IMG_0897.JPG4xscale, the pure white background became "grid"

In video mixer 2.0 everything is good, this problem came out after I upgraded the video mixer IP to version 3.0 cause we upgraded vivado and sdk from 2017.4 to 2018.3, and I didn't change the code. I took a look at the documents of video mixer product guide both v2.0 and v3.0, also did some search on the web, still can't fix this.

So I don't know if I missed something or the video mixer v3.0's memory layer scaling got some bugs with RGBA8(I also tested BGRA8, same result). I need RGB and alpha channel in the memory layer in this project so I only test these 2 color formats. If anyone knows how to fix this kind of problem, please let me know, thanks a lot in advance.



Tags (1)
0 Kudos
1 Reply
Registered: ‎10-04-2017

Re: Video mixer scale problem after upgrading from v2.0 to v3.0

Hi @jackf,


Are you able to attach a simple design showing the issue?

If so, I can verify on my side and take the issue to the Mixer team if there is an issue.




Don't forget to reply, kudo, and accept as solution.

Xilinx Video Design Hub
0 Kudos