UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bilal5330
Visitor
374 Views
Registered: ‎10-01-2019

ZCU106 VCU TRD 2019.1 SDI Tx example not working

Hi, 

I am using ZCU106 VCU TRD 2019.1 examples as it is, i.e. without any compilation or building.
I am able to sucessfully run HDMI Tx example and it can read a TS file from SD Card or USB, decoding it and displaying over monitor (as shown in the image).
However when I run SDI Tx example using same TS file, it gives me error "ERROR: vgst_config_options() failed, error code "VLIB DRM Plane Not Found".
I tried to run the SDI Tx through stream input as well, but it failed too, giving following error "ERROR: vgst_start_pipeline() failed error code "state change failed". 

I was thinking if it had been an input file encoding issue, why did it run in case of HDMI.
I am just passing my own TS file name,  input resolution, and UDP IP information in .cfg files provided in the original TRD, but nothing works.

However I am able to see output monitor tuned up when I run the following command.
$ xmodetest -M xlnx -s 36:1920x1080-60@XV20  -w 36:sdi_mode:2 -w 36:sdi_data_stream:2 -w 36:is_frac:0 &

I am using an SDI to HDMI convertor to get SDI output from ZCU106.

Any guidance and suggestions are highly appreciated as I am a beginner working with VCU TRD.

Thanks in advance.
Bilal

Question.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Tags (5)
0 Kudos
4 Replies
Scholar watari
Scholar
362 Views
Registered: ‎06-16-2013

Re: ZCU106 VCU TRD 2019.1 SDI Tx example not working

Hi @bilal5330 

 

Could you share log file or zoom-up two kind of console's picture ?

It is hard to make sure console messages for me.

 

Best regards

0 Kudos
Highlighted
Visitor bilal5330
Visitor
354 Views
Registered: ‎10-01-2019

Re: ZCU106 VCU TRD 2019.1 SDI Tx example not working

Thanks watari,

I have attached the full log in attachment.

Here is the last excerpt from that log in the bottom.

Note: I am using "inpsdc.cfg" which is a copy of .cfg file provided in TRD for SDI-Tx example. (I have attached it as well).
I am only replacing my TS file name, FPS and resolution information in it. 

Thank you so much again,
Bilal
------------------------------------------------------------------------------------------

root@zcu106_vcu_trd:~# xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
net.core.rmem_default = 60000000
net.core.rmem_max = 60000000
net.core.wmem_default = 60000000
net.core.wmem_max = 60000000
setting mode 3840x2160-60Hz@XV20 on connectors 36, crtc 34
[ 40.254757] xlnx-sdi-tx a0040000.v_smpte_uhdsdi_tx_ss: AXI-4 Stream Underflow error

root@zcu106_vcu_trd:~# cd /media/card/bin
root@zcu106_vcu_trd:/media/card/bin# ls
inpsdc.cfg vcu_gst_app xmedia-ctl xmodetest
root@zcu106_vcu_trd:/media/card/bin# vcu_gst_app inpsdc.cfg
ERROR: vgst_init() failed error code -75 :: "VLIB No media source Available"
Get "VLIB No media source Available" error in Tx only design, can be ignored!!!
/*************************Pipeline Information Start*************************/
Pipeline Info : On
Fps Info : On
APM Info : On
Output goes on : SDI
Frame rate : 50
Number of Source is : 1
Use case is to : Display
Device Type : TPG
Format : NV12
Width : 1920
Height : 1080
Raw : False
Accelerator flag : False
Enable_scd flag : False
Src Type : File Src
URI : file:///media/card/aeroplane.ts
/*************************Pipeline Information End*************************/
ERROR: vgst_config_options() failed, error code "VLIB DRM Plane Not Found"
root@zcu106_vcu_trd:/media/card/bin#

 

0 Kudos
Scholar watari
Scholar
288 Views
Registered: ‎06-16-2013

Re: ZCU106 VCU TRD 2019.1 SDI Tx example not working

Hi @bilal5330 

 

I guess it seems clock source issue from boot log file.

But I don't have any idea to resolve this issue now.

 

Would you make sure clock source and AXI4Streaming clock on SDI Tx ?

 

Best regards,

0 Kudos
Moderator
Moderator
200 Views
Registered: ‎11-21-2018

Re: ZCU106 VCU TRD 2019.1 SDI Tx example not working

Hi @bilal5330 

Do you have any update on this? 

Regards, 

Aoife
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos