UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
235 Views
Registered: ‎12-21-2018

missing qmake_set_env.sh for ZCU106 VCU TRD (2018.3)

Hi,

I'm following the steps from the "Zynq UltraScale+ MPSoC VCU TRD 2018.3 - Run and Build Flow" section. Everything is OK, except that I would like to compile the Qt example App. It's written I must "Source the Qt setup script", but I can't find any script to do that. In other TRD, the instructions mention a script named qmake_set_env.sh. I haven't found that script in $TRD_HOME/apu/apps/vcu_qt. I think it's missing.

Does anybody know what I need to execute before launching qmake (which of course is not in the path at this point) ?

Thank you for your help,

Jeremy

Tags (1)
0 Kudos
4 Replies
Moderator
Moderator
173 Views
Registered: ‎04-12-2017

Re: missing qmake_set_env.sh for ZCU106 VCU TRD (2018.3)

Hello jeremy@easii-ic 

vcu_qt.pro file is part of following path

C:\rdf0428-zcu106-vcu-trd-2018-3\apu\apps\vcu_qtqt.PNG

 

please confirm if you have downloaded the complete files of TRD. If you still don't see it download it again from following path:
 https://www.xilinx.com/member/forms/download/design-license-xef.html?filename=rdf0428-zcu106-vcu-trd-2018-3.zip

Thank you.

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Moderator
Moderator
161 Views
Registered: ‎04-12-2017

Re: missing qmake_set_env.sh for ZCU106 VCU TRD (2018.3)

Hello jeremy@easii-ic 

I wish to add more to my above answer:

May I know if you have built VCU video library and VCU GST library before building the video qt application ?

video qt application will not build without support of above applications.

Please source below files before starting the builds

 source <compiled petalinux bsp path>/images/linux/sdk/environment-setup-aarch64-xilinx-linux

That will set all necessary environment variables required for this project.

Let me know if this work.

Thank you

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
144 Views
Registered: ‎12-21-2018

Re: missing qmake_set_env.sh for ZCU106 VCU TRD (2018.3)

Hi,

I've sourced that script before, but when you look into its content, you can see there is no exported environment variable dealing with Qt.
Looking on other TRDS, I would say 2 files are missing :

- qt.conf
- qmake_set_env.sh.

I've modified the files I have found on a git repo here : https://github.com/radheyxilinx/vcu_qt (maintained by Radhey Shyam Pandey working at Xilinx), to match with my Petalinux environment.

qt.conf :

 

; This file can be edited to change the style of the application
; See Styling Qt Quick Controls 2 in the documentation for details:
; http://doc.qt.io/qt-5/qtquickcontrols2-styles.html

[Controls]
Style=Default

[Universal]
Theme=Light
;Accent=Steel

[Material]
Theme=Light
;Accent=BlueGrey
;Primary=BlueGray

[Paths]
Prefix = $($SDKTARGETSYSROOT)/usr
Headers = include/qt5
Libraries = lib
ArchData = lib/qt5
Data = share/qt5
Binaries = bin/qt5
LibraryExecutables = lib/qt5/libexec
Plugins = lib/qt5/plugins
Imports = lib/qt5/imports
Qml2Imports = lib/qt5/qml
Translations = share/qt5/translations
Documentation = share/doc/qt5
Settings = qt5
Examples = share/qt5/examples
Tests = share/qt5/tests
HostData = lib/qt5
HostLibraries = lib
HostSpec = lib/qt5/mkspecs/linux-oe-g++
ExternalHostBinaries = $(PETALINUX)/components/yocto/source/aarch64/buildtools/sysroots/x86_64-petalinux-linux/usr/bin/qt5

qmake_set_env.sh :

 

#!/bin/sh

# test environment variables
: "${TRD_HOME:?environment variable not set or empty}"
: "${PETALINUX:?environment variable not set or empty}"

# set environment variables
export MAKEFLAGS='-j 20' \
OE_QMAKE_AR='aarch64-linux-gnu-ar' \
OE_QMAKE_CC='aarch64-linux-gnu-gcc  -Wl,--hash-style=gnu ' \
OE_QMAKE_CFLAGS=' -O2 -pipe -g -feliminate-unused-debug-types' \
OE_QMAKE_COMPILER='aarch64-linux-gnu-gcc  -Wl,--hash-style=gnu ' \
OE_QMAKE_CXX='aarch64-linux-gnu-g++  -Wl,--hash-style=gnu ' \
OE_QMAKE_CXXFLAGS=' -O2 -pipe -g -feliminate-unused-debug-types -fvisibility-inlines-hidden' \
OE_QMAKE_LDFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' \
OE_QMAKE_LINK='aarch64-linux-gnu-g++  -Wl,--hash-style=gnu ' \
OE_QMAKE_STRIP='echo' \
SYSROOT=$SDKTARGETSYSROOT \
PATH=$PETALINUX/components/yocto/source/aarch64/buildtools/sysroots/x86_64-petalinux-linux/usr/bin/qt5:$PATH \
QT_CONF_PATH=$TRD_HOME/apu/vcu_qt/qt.conf

# test existence of SYSROOT directory
if [ ! -d "$SDKTARGETSYSROOT" ]
then
  echo "$SDKTARGETSYSROOT directory $SDKTARGETSYSROOT does not exist!"
fi

# generate Makefile
echo "To generate the Makefile, run the following command chosing the desired Qt project file:"
echo "qmake \$TRD_HOME/apu/vcu_qt/vcu_qt.pro -r -spec linux-oe-g++"
[jeremy@fxeasii092-centosVM vcu_qt]$ 

after having sourced qmake_set_env.sh, I've succesffuly built the qmake project :

make vcu_qt.pro -r -spec linux-oe-g++

According to the screenshot you've posted, I really think these 2 files are missing from the TRD sources.

0 Kudos
Moderator
Moderator
50 Views
Registered: ‎11-09-2015

Re: missing qmake_set_env.sh for ZCU106 VCU TRD (2018.3)

HI jeremy@easii-ic ,

Sorry about the delay.

@kvasantr was right, what you really need to source to have qmake is source <compiled petalinux bsp path>/images/linux/sdk/environment-setup-aarch64-xilinx-linux.

The qmake is located in the sysroot build by petalinux, so I am quite sure the steps you were missing was in building the petalinux project:

petalinux-package --sysroot

I confirmed this today, I can get qmake if I source environment-setup-aarch64-xilinx-linux with sysroot built from petalinux

Thus, no file is missing from the VCU TRD.

Best Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos