UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
899 Views
Registered: ‎02-08-2018

vivado 2017.4 tpg initializing issue

Hello,

       How to activate register settings in TPG to make it active?

       i have written program to activate TPG ,

       Please let me know any issue in this attached file and Please send the activated TPG program.

 

 

 

 

 

 

Thanks,

Nishith

0 Kudos
4 Replies
Moderator
Moderator
822 Views
Registered: ‎11-09-2015

Re: vivado 2017.4 tpg initializing issue

HI @nishith.kumar,

 

The test pattern generator needs to be started. Usually by writing 0x81 at address 0x0.

 

Note 1 : You can generate an example design for the TPG for reference for both HW and SW. Refer to chapter 6 of pg103.

 

Note 2 : You might want to look at my Xilinx Video Series. I use the TPG in simulation in many of them.


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Moderator
Moderator
726 Views
Registered: ‎11-09-2015

Re: vivado 2017.4 tpg initializing issue

Hi @nishith.kumar,

 

Was this solved for you?

 

If your question is answered or your issue is solved, please kindly mark the response which helped as solution (click on "Accept as solution" buton below the reply)

If this is not solved/answered, please reply in the topic giving more information on your current status.

Thanks and Regards,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Contributor
Contributor
695 Views
Registered: ‎02-08-2018

Re: vivado 2017.4 tpg initializing issue

 Hello @florentw,

                          Thanks you for your response. Anyway i have solved this issue by myself long ago.

 

 

Thanks and Regards

Nishith Kumar

0 Kudos
Moderator
Moderator
678 Views
Registered: ‎11-09-2015

Re: vivado 2017.4 tpg initializing issue

HI @nishith.kumar,

 

Could you kindly share what was your solution with the community and mark it as accepted solution (click on accept as solution below the reply while logged in)?

 

Thanks,


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos