Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎08-12-2015

problem to program virtex 5

hi, I have a problem to program virtex 5 with programer,395,716&Prod=XUP-USB-JTAG this a log of console GUI --- Auto connect to cable... INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.3 INFO:iMPACT - Digilent Plugin: no JTAG device was found. AutoDetecting cable. Please wait. *** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates PROGRESS_START - Starting Operation. Connecting to cable (Usb Port - USB21). Checking cable driver. Driver file xusb_emb.sys found. Driver version: src=1029, dest=1029. Driver windrvr6.sys version = WinDriver v10.21 Jungo (c) 1997 - 2010 Build Date: Aug 31 2010 x86_64 64bit SYS 14:14:44, version = 1021. Cable PID = 0008. Max current requested during enumeration is 74 mA. Type = 0x0004. Cable Type = 3, Revision = 0. Setting cable speed to 6 MHz. Cable connection established. Firmware version = 1303. File version of C:/Xilinx/14.3/ISE_DS/ISE/data/xusb_xlp.hex = 1303. Firmware hex file version = 1303. PLD file version = 0012h. PLD version = 0012h. PROGRESS_END - End Operation. Elapsed time = 0 sec. Type = 0x0004. ESN device is not available for this cable. Attempting to identify devices in the boundary-scan chain configuration... INFO:iMPACT - Current time: 13/08/2015 15:47:43 PROGRESS_START - Starting Operation. Identifying chain contents...'0': : Manufacturer's ID = Unknown INFO:iMPACT:501 - '1': Added Device UNKNOWN successfully. ---------------------------------------------------------------------- ---------------------------------------------------------------------- INFO:iMPACT:1588 - '1':The part does not appear to be Xilinx Part. '1': : Manufacturer's ID =Unknown , Version : 5 INFO:iMPACT:501 - '1': Added Device UNKNOWN successfully. ---------------------------------------------------------------------- ---------------------------------------------------------------------- INFO:iMPACT:1588 - '2':The part does not appear to be Xilinx Part. '2': : Manufacturer's ID =Unknown , Version : 15 INFO:iMPACT:501 - '1': Added Device UNKNOWN successfully. ---------------------------------------------------------------------- ---------------------------------------------------------------------- done. PROGRESS_END - End Operation. Elapsed time = 1 sec. thanks
0 Kudos
3 Replies
Registered: ‎07-09-2009

you might want to check this digilent programmer works with the 14.3 version of ISE, I'm not certain it does or at least needs a special digilent driver. Have you tried the digilent program ?
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Community Manager
Community Manager
Registered: ‎07-23-2012

Try to reduce the cable speed and see if the device gets detected or not. You can also run IDCODE looping test from impact to check the quality of the JTAG chain.
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos
Registered: ‎03-06-2014



I had this problem before and I got it solved and I want to share it with you to eliminate this problem. On the Virtex-5 Board as you may see there must be two mini-USB ports; one of them is regular FPGA progreamming via iMPACT software and the other port is dedicated for programming via DIGILENT software and it is called the digilent usb port. There might be two reasons why you get this error. I mean using the USB cable:

1. The mini-USB tail was wrongly connected on the board, check it please.


2. Becareful if the iMPACT wizard is open and you did some trial with it before, the board will be confused to recognize the Digilent port. first turn off the iMPACT wizard if it is open and reset your board, then ONLY try with Digilent software. Please keep noticed that iMPACT and Digilent are two separate ways of programming the FPGA and must not be interrupted by each other.


Hope this can solve the problem...



0 Kudos