cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
239 Views
Registered: ‎06-15-2020

Disable auto frequency scaling in Vitis IDE

Hello! I was doing a hardware build in my project with Vitis, and the system guidance report shows that auto frequency scaling has lowered the frequency from 250 MHz to 12.2 MHz. I am wondering how I can disable this auto frequency scaling option in the Vitis IDE? I have read about this article and seems like the feature can be disabled by setting compilation flags, but I am not sure where in the Vitis IDE can I set such flags.

I have poked around and suspect that I can set it with build configuration settings -> edit toolchain compiler settings and pass the flag under V++ Kernel Compiler -> Miscellaneous (please see the screenshot attached below). Is this the correct way to pass on such flags to the compiler?

Thank you!

Owenoool

 

xilinx_vitis_flag_question.PNG

2 Replies
Highlighted
Moderator
Moderator
85 Views
Registered: ‎09-12-2007

This should be fine, you can check the resulting command line. However, I normally do this as shown below:

vpluspluss.PNG

Highlighted
Moderator
Moderator
56 Views
Registered: ‎11-04-2010

In the below pic, there are two "Miscellaneous", 1 for compile stage and 2 for link stage.

Only setting the Kernel frequency in "Miscellaneous" for link (2nd red rectangle), the frequency setting will override the default one during Vitis Platform Link stage (Take effect finally).

You can refer to the post for the way to verify whether the kernel frequency setting works or not.

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
link22.png
0 Kudos