cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
curlywei
Observer
Observer
199 Views
Registered: ‎09-12-2020

Error when build FSBL for zynq-7000 using xsct

Jump to solution

Here is my tcl script for build

set kAPPName "xvc_fsbl"
set kPlatformName "${kAPPName}_pf"
set kDomainName "${kAPPName}_dom"
set kXSAFilePath "xvc_server_hw/xvc_system_top.xsa"
set kOutputDir "xvc_server_os" 

setws ${kOutputDir}

platform create \
  -name ${kPlatformName} \
  -hw ${kXSAFilePath}

domain create \
  -name ${kDomainName} \
  -os standalone \
  -proc ps7_cortexa9_0

platform generate

app create \
  -name ${kAPPName} \
  -platform ${kPlatformName} \
  -domain ${kDomainName} \
  -template {Zynq FSBL}

 

The xsa file  "xvc_system_top.xsa" I bring from vivado command

write_hw_platform -fixed -include_bit -force -verbose xvc_system_top.xsa

when I run 

$ xsct -eval source ../src/os/gen_fsbl.tcl

 

I got this error message

Specified template name Zynq FSBL is not valid for configuration. Reason: This application requires xilffs library in the Board Support Package.. List of valid names are Hello World, Memory Tests, Zynq DRAM tests, Peripheral Tests, Dhrystone, Empty Application.
    while executing
"error [dict get $msg err]"
    (procedure "xsdk_eval" line 15)
    invoked from within
"xsdk_eval $chan "XSDx" createAppFromPlatform "o{$fmt}" e [list $data]"
    (procedure "app" line 382)
    invoked from within
"app create \
  -name ${kAPPName} \
  -platform ${kPlatformName} \
  -domain ${kDomainName} \
  -template {Zynq FSBL}"
    (file "../src/os/gen_fsbl.tcl" line 20)

 

I thought the reason is because I specify "part-name" instead of "BOARD_PART" when I build vivado project, I'm not sure.

Has any suggestion?

 

 

 

0 Kudos
1 Solution

Accepted Solutions
pvempati
Xilinx Employee
Xilinx Employee
170 Views
Registered: ‎01-03-2017

Hi @curlywei ,

The above error is expected. This is due FSBL application requires xilffs library. which is not available in this domain. 

Please use the below command after creation of the domain to enable the xilffs library in the domain. then run the platform generate command like below

 

bsp setlib xilffs
platform generate
then... create the application
app create  

Please let me know if you see any issue again.

 

Thanks & Regards,

Praveen Kumar. V

 

View solution in original post

0 Kudos
1 Reply
pvempati
Xilinx Employee
Xilinx Employee
171 Views
Registered: ‎01-03-2017

Hi @curlywei ,

The above error is expected. This is due FSBL application requires xilffs library. which is not available in this domain. 

Please use the below command after creation of the domain to enable the xilffs library in the domain. then run the platform generate command like below

 

bsp setlib xilffs
platform generate
then... create the application
app create  

Please let me know if you see any issue again.

 

Thanks & Regards,

Praveen Kumar. V

 

View solution in original post

0 Kudos