cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
574 Views
Registered: ‎09-12-2018

Failed comparing software and hardware performance

Jump to solution
 

Hi, I tried to compare software and hardware performance with the bilateral_filter template in ZCU104 platform. But there is a warning and can not get the comparation of the software and hardware performance. 


WARNING: [PerfEst 83-3800] Software run data for function xf::bilateralFilter<3,1,0,2160,3840,1> not found in file swdata.xml. Continuing without comparison to software run data
For graph with functions: xf::bilateralFilter<3,1,0,2160,3840,1>:xf_bilateral_filter_accel.cpp:34
Estimated hardware latency = 33887482
Estimated resource usage:
dsps used = 17/1728
bram used = 20/312
luts used = 18742/230400
FFs used = 19239/460800image.png

How can I solve this problem?

Many thanks.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
481 Views
Registered: ‎09-12-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi, I found out what my problem was. Because I didn't choose the Standalone as System configuration.

View solution in original post

0 Kudos
5 Replies
Highlighted
Moderator
Moderator
566 Views
Registered: ‎08-20-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi @yan0110 

Is your host remote?

Best Regards,
Nutan
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
Highlighted
Contributor
Contributor
531 Views
Registered: ‎09-12-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi, @nutang. Thanks for your reply.

I ran the demo in SDSoC and I also configurated the IP. 

QQ截图20190521142326.jpg

I did the Performance Estimation according to the SDSoC Environment Tutorial: Introduction(https://github.com/Xilinx/SDSoC-Tutorials/blob/master/getting-started-tutorial/lab-2-performance-estimation.md). I can run the demo using "./ bilateral_filter.elf im0.jpg" command in Tera Term, but I don't knowl how to collect software run data. When I clicked the Click Here, there was also the same warning:

WARNING: [PerfEst 83-3800] Software run data for function xf::bilateralFilter<3,1,0,2160,3840,1> not found in file swdata.xml. Continuing without comparison to software run data
For graph with functions: xf::bilateralFilter<3,1,0,2160,3840,1>:xf_bilateral_filter_accel.cpp:34
Estimated hardware latency = 33887482
Estimated resource usage:
dsps used = 17/1728
bram used = 20/312
luts used = 18742/230400

Hope to your reply.

Many thanks.

 

0 Kudos
Highlighted
Moderator
Moderator
515 Views
Registered: ‎08-20-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi @yan0110 

Please let me know your SDSoC version

Also, confirm if you are connecting board remotely or to the local host.

Best Regards,
Nutan
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
Highlighted
Contributor
Contributor
503 Views
Registered: ‎09-12-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi, @nutang. Thanks for your reply.

Both of the version of my SDSoC and reVISION Stack are 2018.3. And I connected the ZCU104 board to my local PC.

Many thanks.

0 Kudos
Highlighted
Contributor
Contributor
482 Views
Registered: ‎09-12-2018

Re: Failed comparing software and hardware performance

Jump to solution

Hi, I found out what my problem was. Because I didn't choose the Standalone as System configuration.

View solution in original post

0 Kudos