cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
goahead97
Participant
Participant
192 Views
Registered: ‎01-29-2021

How do I get rid of the error "Unable to load Tcl app xilinx::modelsim" in (Xilinx Vitis IDE v2020.2.0 (64-bit))?

Hello

 

How do I get rid of the following error displayed on Vitis console under Ubuntu?

 

 

===>The following messages were generated while running Vivado to generate simulation models and scripts. Log file: /media/x/forVitis/workspace_1/vadd_system_hw_link/Emulation-HW/binary_container_1.build/link/vivado/vpl/runme.log :
ERROR: [VPL 17-685] Unable to load Tcl app xilinx::modelsim
ERROR: [VPL 60-773] In '/media/x/forVitis/workspace_1/vadd_system_hw_link/Emulation-HW/binary_container_1.build/link/vivado/vpl/runme.log', caught Tcl error: ERROR: [Common 17-69] Command failed: ERROR: [Common 17-685] Unable to load Tcl app xilinx::modelsim
ERROR: [VPL 60-704] Integration error, Step failed: create_project An error stack with function names and arguments may be available in the 'vivado.log'.
ERROR: [VPL 60-1328] Vpl run 'vpl' failed
ERROR: [VPL 60-806] Failed to finish platform linker
INFO: [v++ 60-1442] [18:32:34] Run run_link: Step vpl: Failed
Time (s): cpu = 00:00:16 ; elapsed = 00:00:31 . Memory (MB): peak = 1597.395 ; gain = 0.000 ; free physical = 669 ; free virtual = 9790
ERROR: [v++ 60-661] v++ link run 'run_link' failed
ERROR: [v++ 60-626] Kernel link failed to complete
ERROR: [v++ 60-703] Failed to finish linking
INFO: [v++ 60-1653] Closing dispatch client.
makefile:61: recipe for target 'binary_container_1.xclbin' failed
make: *** [binary_container_1.xclbin] Error 1

 

 

Moreover, trying to launch the RTL kernel wizard outputs a similar error as you can see in attachment.

Thanks 

Unable to load Tcl app xilinx::modelsim.png
0 Kudos
Reply
3 Replies
hongh
Moderator
Moderator
155 Views
Registered: ‎11-04-2010

Please try to removed the .Xilinx folder in your home dir.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Reply
goahead97
Participant
Participant
129 Views
Registered: ‎01-29-2021

I do not see any ".Xilinx" folder in my home directory. I do not see it even if I take a look at hidden folders within the home folder.

0 Kudos
Reply
goahead97
Participant
Participant
76 Views
Registered: ‎01-29-2021

I was looking for the ".Xilinx" in the wrong folder. I was look for this folder under 

 

 

/home

 

 

but it was not there.

Eventually I found the ".Xilinx" folder in

 

 

/home/$username

 

 

Then I removed it. And now I get the error displayed in attachment when I try to launch Vitis. And for some strange reason running Vitis or Vivado from terminal leaves shortcuts such us for example ctrl+alt + T and the terminal command "ls" inoperative. I get 

 

 

 

 

ls: command not found

 

 

 

 

Moreover, the taskbar goes missing after trying to launch Vitis or Vivado.

 

IMG_20210224_093116.jpg
0 Kudos
Reply