cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
zengsl
Visitor
Visitor
280 Views
Registered: ‎12-27-2019

KCU1500 board installation failed

I followed the instructions in ug1260 to install the KCU1500 board based on SDAccel 2018.2. Step1-3 went well but things were different at step 4 as below:

 

1)xbsak flash scan:showed no devices

2)lspci -d 10ee:

03:00.0 FLASH memory: Xilinx Corporation Device 8038

according to ug1260,it should be 'serial controller' instead of 'FLASH memory'

3)lspci -vd 10ee:

03:00.0 FLASH memory: Xilinx Corporation Device 8038
Subsystem: Xilinx Corporation Device 0007
Flags: bus master, fast devsel, latency 0
Memory at 90300000 (32-bit, non-prefetchable) [size=1M]
Memory at 90400000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>

according to this link,https://forums.xilinx.com/t5/Vitis-SDAccel-and-SDSoC/Error-No-devices-found-KCU1500/m-p/1017008 ,the drivers weren't installed correctly.

4)xbsak list

Unable to open /sys/bus/pci/devices/0000:03:00.0/userbar
Could not open file: /sys/bus/pci/devices/0000:03:00.0/userbar

5)  sudo ./runtime/bin/xbflash -m ./firmware/xilinx_kcu1500_dynamic_5_0_primary.mcs -n ./firmware/xilinx_kcu1500_dynamic_5_0_secondary.mcs

XBFLASH -- Xilinx Board Flash Utility
primary mcs: ./firmware/xilinx_kcu1500_dynamic_5_0_primary.mcs
secondary mcs: ./firmware/xilinx_kcu1500_dynamic_5_0_secondary.mcs
ERROR: Invalid device index.
ERROR: Failed to map pcie device.
XBFLASH failed.

other infos:

1)I tried to reboot the server, but it didn't work

2)My colleague once flashed some PCIE program based on Vivado 2018.2 into this board and it went well. But it went wrong when I tried it with SDAccel 2018.2 flow.

Any suggestions would be helpful.

Best Regards,

Shulin

0 Kudos
0 Replies