cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
Newbie
569 Views
Registered: ‎12-12-2019

Vitis Linux Application Project - linux not an option

I want to create a new Linux Application Project.  I click File -> New -> Application Project, enter project name and click Next.  Not seeing my board listed under either tab, I click + to create a new platform.  I select the .xsa file for my Vivado project (swe_gwe_comm_top.xsa) and click Next.  Now I want to select Linux as the OS, but alas, it is not an option.  I can select standalone or freeRTOS.  What would cause linux to not be shown?

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
534 Views
Registered: ‎02-27-2019

Hi @rodneyheil ,

Linux application is for acceleration flow,  you need to download the edge platform https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-platforms.html and install it. For details, refer to  https://www.xilinx.com/support/documentation/sw_manuals/xilinx2019_2/ug1393-vitis-application-acceleration.pdf

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Voyager
Voyager
432 Views
Registered: ‎05-25-2016

I have the same problem and UG1392 you linked seems to be no help.  I think page 155 was the section of that documenting you were alluding to with the above post.  Unfortunately this is not helpful at all.

How does one get a basic hello world linux application to work on a standard zynq 7020 part?  For example, I'm using the zedboard.  The option for linux as the OP said is not available.  

0 Kudos
Highlighted
Moderator
Moderator
393 Views
Registered: ‎08-20-2018

Hi @rodneyheil 

Linux option is not there by default.

Please follow below steps.

1. Create a platform project with your XSA for standalone OS.

2. After the creation, navigate to platform project and open platform.spr

3. Add new domain

add_domain.PNG

4. Select linux OS from the dropdown

linux_domain.PNG

5. Update the path of all required Linux boot files. After this, you will see an out-of-date tag for your platform. Right-click and build the project.

6. Create a new application project and select this custom platform that you created above. do not create a new one using the same XSA. You will see the linux domain here.

Best Regards,
Nutan
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
0 Kudos
Voyager
Voyager
376 Views
Registered: ‎05-25-2016

I think I was also confused because the platform seems to have to compile to show up as a supported platform when creating a new project. To compile it you have to generate a bif and I used the petalinux-package command which creates a bif.  Once this was untangled the project flow began to work.

0 Kudos