cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kbj1213
Contributor
Contributor
307 Views
Registered: ‎08-25-2015

Vitis UART Serial communication for Zynq

Hi, I'm going through ug1209 (Zynq Ultrascale+ MPSoC:Embedded Design Tutorial) for Vitis 2020.1.

I'm doing it on Ubuntu.

When I tried to do what is on 34 page of ug 1209 (sending "Hello World" string to the UART0 peripheral of PS), my Terminal showed nothing.

 

I want to do UART communication by USB Type-A to USB Micro cable (Ubuntu PC to ZCU102 board)

(ttyS0 is jtag for FPGA configuration)

1.png

 

The following figure is my Serial Terminal Setting.

 

2.png

 

 

After I do run configuration, nothing happens on ttyUSB2 Terminal.

 

 

3.png

 

Is there anything I could try for debugging?

0 Kudos
4 Replies
dylancob
Contributor
Contributor
279 Views
Registered: ‎07-22-2020

 Not sure if this will fix it since I don't run Linux, but try changing flow control to software (Xon/Xoff)

I had a similar terminal problem that was fixed when I did that, but yours could be something else.. Just something to try!

kbj1213
Contributor
Contributor
235 Views
Registered: ‎08-25-2015

Thank you for your advice. I tried it in Vitis Terminal setting, but it doesn't work for 1) None 2) Hardware 3) Software flow control all....

0 Kudos
dylancob
Contributor
Contributor
195 Views
Registered: ‎07-22-2020

Interesting.. Are you connecting to the terminal before or after you run the program? Is it possible you are just missing the string it is printing?

kbj1213
Contributor
Contributor
183 Views
Registered: ‎08-25-2015

I connect to the terminal before running program.....

Well... I couldn't check whether I missed it.

 

Just..... resolved this problem by using other PC (windows)