cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sngo
Visitor
Visitor
452 Views
Registered: ‎11-07-2019

Vitis platform build errors

I am doing a simple hello world and LED control with the zcu 104 exported hardware from Vivado.  I was able to get this working with two domains in the platform.  However, it took a couple of days to get this to build error free.  Everytime I would build it would be a different error, and eventually none. 

I then wanted to try to get 4 domains and 4 apps working.  I am on 2.5 days of building this platform.  I have not been error free, and the errors are not consistent.  

Has anyone else experienced this?  Why does this happen?  Was Vitis released too soon?

0 Kudos
4 Replies
nutang
Moderator
Moderator
424 Views
Registered: ‎08-20-2018

Hi @sngo 

Please give us more details on Vivado design.

Can you share the XSA file?

Best Regards,
Nutan
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
0 Kudos
sngo
Visitor
Visitor
391 Views
Registered: ‎11-07-2019

Capture.PNG

 

When I try to attach it I get this error

 

0 Kudos
sngo
Visitor
Visitor
384 Views
Registered: ‎11-07-2019

Capture.PNG

I have done this design without the timer and LED_CTRL (I just recently added them in.  It is not a complicated design.  It is just for me to gain and understanding of how things work.

0 Kudos
rajut
Xilinx Employee
Xilinx Employee
316 Views
Registered: ‎12-21-2016

Hi,

Please zip the XSA and share it, we will look into it. 

Regards,
Raju
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

0 Kudos