cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
228 Views
Registered: ‎02-06-2018

XRT installation ERROR

Hi all, 

The building env is as follows:

install package: xrt_202010.2.6.655_16.04-amd64-xrt.deb

install guidance: https://www.xilinx.com/html_docs/xilinx2020_1/vitis_doc/pjr1542153622642.html

install command: sudo apt install ./xrt_202010.2.6.655_16.04-amd64-xrt.deb

Build OS: 4.15.0-112-generic #113~16.04.1-Ubuntu SMP Fri Jul 10 04:37:08 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

 

During the installation of XRT, some ERRORs occur:

 

rmmod: ERROR: Module xocl is not currently loaded
rmmod: ERROR: Module xclmgmt is not currently loaded

And some warnnigs occur:

N: Can't drop privileges for downloading as file '/home/kn/Downloads/xilinx/Vitis_Embedded_Platforms/0Xilinx Runtime - 2020.1/XRT_package/xrt_202010.2.6.655_16.04-amd64-xrt.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Should I need to fix these? Please somebody help me.

The attachment is install log in case anyone wants a whole picture. 

 

 

0 Kudos
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
140 Views
Registered: ‎07-17-2018

Hi 

if it is the first time to install the xrt, the following is normal.

rmmod: ERROR: Module xocl is not currently loaded
rmmod: ERROR: Module xclmgmt is not currently loaded

 the second warning

it looks like a priviledge problme, please  try to install in the root, it may solve it. 

Highlighted
Visitor
Visitor
116 Views
Registered: ‎02-06-2018

Hi minx

Thank you very much.

About “priviledge problme ”, the install command is "sudo apt install ./xrt_202010.2.6.655_16.04-amd64-xrt.deb". However, the warning is till there.....

0 Kudos