cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
johank
Observer
Observer
267 Views
Registered: ‎09-02-2018

XUSB Examples

Hello Xilinx Forum,

 

I'm playing around with the XUSB examples as delivered with the XUSB drivers. And they work fine. Except when I try to switch to computers running Windows. 

I've focussed on the "XUSB Audio" examples, both the FreeRTOS-based and the bare-metal one. When I run them and try to connect them to Windows, I always get "This device is not starting. (Code 10)" error in the device manager. 

 

The fact that they run fine when connected to a Linux machine, rules out the hardware and the FPGA-configuration, I would say. I've tried several cables, several machines (windows 7, Windows 10) and several configurations, there's always the same problem. 

 

I've captured USB traffic on both a Linux-machine and a Windows-machine. They don't look familiar at all, but that might be due to the fact that they are both captured with different programs. Anyway, this is all the traffic I can capture with a Windows-machine:

Naamloos.png

 

Output on the serial terminal shows some more sending/receiving of packets then my capture shows, so I kind of doubt the quality of this capture. 

 

However, because the software runs fine onder Linux, I would say that something weird is going on with the Windows USB-stack and this has to be accounted/corrected for in the PS-software. The software is running on an ZCU104 dev-board with USB connected to J96, the USB 2.0/USB 3.0 connector.

 

Did someone managed to make this work and/or can someone point me in the right direction for fixing this?

 

Thank you very much!

 

With kind regards,

 

Johan

 

0 Kudos
0 Replies