cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
504 Views
Registered: ‎08-09-2020

recipe for target 'binary_container_1.xclbin' failed make: *** [binary_container_1.xclbin] Error 1

Jump to solution

Hi,

I am currently working with Vitis 2020.1 and trying to program on my Alveo U50 boards with a simple program on Ubuntu 18.04. I think I have successfully installed the Xilinx Runtime, Deployment target platform, development, and Development target platform.

 

I have successfully passed the Emulation-SW test, but when I tried to make the Emulation-HW test.

I am getting an 2 errors, while building the application in Vitis (using vector addition template)

make:***[binary_container_1.xclbin] Error 1 (resource Hardware).

 

I am also confused about the procedure to make an application program on Vitis Platform since I cannot find related documentation for developing application on Alveo U50 using Vitis. Do I need to create a xsa file using vivado in order to transfer the program written on Vitis to my Alveo card.

 

The following is error shown on the console after the Hardware Emulation

[09:03:01] Run vpl: Step create_project: Completed
[09:03:01] Run vpl: Step create_bd: Started
[09:03:58] Run vpl: Step create_bd: Completed
[09:03:58] Run vpl: Step update_bd: Started
[09:04:03] Run vpl: Step update_bd: Completed
[09:04:03] Run vpl: Step generate_target: Started
[09:05:18] Run vpl: Step generate_target: RUNNING...
[09:05:51] Run vpl: Step generate_target: Completed
[09:05:51] Run vpl: Step config_hw_emulation: Started
[09:07:07] Run vpl: Step config_hw_emulation: RUNNING...
[09:07:40] Run vpl: Step config_hw_emulation: Failed
[09:07:45] Run vpl: FINISHED. Run Status: config_hw_emulation ERROR
ERROR: [VPL 60-773] In '/root/workspace/test1/Emulation-HW/binary_container_1.build/link/vivado/vpl/runme.log', caught Tcl error: ./elaborate.sh: line 20: LIBRARY_PATH: unbound variable
ERROR: [VPL 60-2373] In '/root/workspace/test1/Emulation-HW/binary_container_1.build/link/vivado/vpl/runme.log', caught error: ERROR: caught error: ./elaborate.sh: line 20: LIBRARY_PATH: unbound variable
ERROR: [VPL 60-2373] In '/root/workspace/test1/Emulation-HW/binary_container_1.build/link/vivado/vpl/vivado.log', caught error: ERROR: caught error: ./elaborate.sh: line 20: LIBRARY_PATH: unbound variable
ERROR: [VPL 60-1328] Vpl run 'vpl' failed
ERROR: [VPL 60-806] Failed to finish platform linker
INFO: [v++ 60-1442] [09:07:45] Run run_link: Step vpl: Failed
Time (s): cpu = 00:24:43 ; elapsed = 00:05:07 . Memory (MB): peak = 1341.258 ; gain = 0.000 ; free physical = 121266 ; free virtual = 127964
ERROR: [v++ 60-661] v++ link run 'run_link' failed
ERROR: [v++ 60-626] Kernel link failed to complete
ERROR: [v++ 60-703] Failed to finish linking
INFO: [v++ 60-1653] Closing dispatch client.
makefile:92: recipe for target 'binary_container_1.xclbin' failed
make: *** [binary_container_1.xclbin] Error 1

09:07:45 Build Finished (took 6m:34s.726ms)

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
490 Views
Registered: ‎11-04-2010

For Ubuntu OS, please run the below command before launching Vitis:

export LIBRARY_PATH=/usr/lib/x86_64-linux-gnu

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

4 Replies
Highlighted
Moderator
Moderator
491 Views
Registered: ‎11-04-2010

For Ubuntu OS, please run the below command before launching Vitis:

export LIBRARY_PATH=/usr/lib/x86_64-linux-gnu

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Highlighted
Visitor
Visitor
482 Views
Registered: ‎08-09-2020
I retried that using your method but it is still not working, is it because I did not generate a xsa file for u50 using vivado?
0 Kudos
Highlighted
Moderator
Moderator
479 Views
Registered: ‎11-04-2010

For u50, you don't need to generate XSA. 

Please confirm that you close the Vitis and relaunch it after setting the environment variable.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
83 Views
Registered: ‎11-10-2020

Have you solved the problem? I've encountered a similar error and the LIBRARY_PATH didn't work neither.

0 Kudos