UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor meven
Visitor
1,592 Views
Registered: ‎06-25-2018

SDAccel 2018.2 fail to link libdpi.so

Jump to solution

Hi,

I'm trying to run HW emulation for the vadd example in SDx but I have an error :

 

14:18:56 **** Incremental Build of configuration Emulation-HW for project vadd ****
make -j1 incremental 
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/xocc -t hw_emu --platform xilinx_kcu1500_dynamic_5_0 --save-temps   -l --nk krnl_vadd:1:krnl_vadd_1 -g --messageDb krnl_vadd.mdb --xp misc:solution_name=link --temp_dir krnl_vadd --report_dir krnl_vadd/reports --log_dir krnl_vadd/logs --remote_ip_cache /home/sinitame/SDX/ip_cache -o"krnl_vadd.xclbin" krnl_vadd/krnl_vadd.xo

****** xocc v2018.2 (64-bit)
  **** SW Build 2258646 on Thu Jun 14 20:02:38 MDT 2018
    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

INFO: [XOCC 60-629] Linking for hardware emulation target
WARNING: [XOCC 60-1140] Rule service exception in startRuleCheckSession. Design Guidance report may not be produced. Exception: write: Broken pipe
INFO: [XOCC 60-895]   Target platform: /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/platforms/xilinx_kcu1500_dynamic_5_0/xilinx_kcu1500_dynamic_5_0.xpfm
INFO: [XOCC 60-423]   Target device: xilinx_kcu1500_dynamic_5_0
INFO: [XOCC 60-825] xocc command line options for sdx_link are --xo krnl_vadd/krnl_vadd.xo --nk krnl_vadd:1:krnl_vadd_1 -keep 
using /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/platforms/xilinx_kcu1500_dynamic_5_0/xilinx_kcu1500_dynamic_5_0.xpfm
extracting xo v3 file /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/krnl_vadd.xo
Creating IP database /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/sys_link/_sds/.cdb/xd_ip_db.xml
processing accelerators: /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/sys_link/iprepo/xilinx_com_hls_krnl_vadd_1_0
ip_dir: /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/sys_link/iprepo/xilinx_com_hls_krnl_vadd_1_0
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/xsltproc --stringparam xpath "spirit:component/spirit:name/text()" /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/scripts/xdcc/xpathValueOf.xsl /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/sys_link/iprepo/xilinx_com_hls_krnl_vadd_1_0/component.xml
ip_name: krnl_vadd
Creating apsys_0.xml
INFO: [CFGEN 83-0] Kernel Specs: 
INFO: [CFGEN 83-0]   kernel: krnl_vadd, num: 1, inst(0): krnl_vadd_1

Creating dr.bd.tcl
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf2xd: 4: /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf2xd: [[: not found
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf2xd: 4: /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf2xd: [[: not found
INFO: [CF2XD 83-2203] Adding accelerator adapters...
INFO: [CF2XD 83-2200] Adding axi_interconnects...
INFO: [CF2XD 83-2201] Adding axi_stream_router for scatter-gather DMAs...
INFO: [CF2XD 83-2202] Adding axi_dwidth_converters...
INFO: [CF2XD 83-2208] Adding bus connections for logical connections...
INFO: [CF2XD 83-2205] Adding clock connections...
INFO: [CF2XD 83-2206] Adding reset connections...
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf_xsd: 4: /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf_xsd: [[: not found
/media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf_xsd: 4: /media/sinitame/Secure_HDD/Xilinx/SDx/2018.2/bin/cf_xsd: [[: not found
INFO: [XOCC 60-812] xocc command line options for vpl are -t hw_emu -f xilinx_kcu1500_dynamic_5_0 --nk krnl_vadd:1:krnl_vadd_1 --xp param:compiler.enablePerformanceTrace=1 --xp misc:report=type report_timing_summary name impl_report_timing_summary_route_design_summary steps {route_design} runs {impl_1} options {-max_paths 10} --xp vivado_prop:run.__KERNEL__.{STEPS.SYNTH_DESIGN.ARGS.MORE OPTIONS}={-directive sdx_optimization_effort_high} --xp param:compiler.enableRunInBitstreamGeneration=1 --xp misc:solution_name=link -g -s --remote_ip_cache /home/sinitame/SDX/ip_cache 

****** vpl v2018.2 (64-bit)
  **** SW Build 2258646 on Thu Jun 14 20:02:38 MDT 2018
    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

Attempting to get a license: ap_opencl
Feature available: ap_opencl
INFO: [VPL 60-839] Read in kernel information from file '/home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/int/kernel_info.dat'.
INFO: [VPL 60-423]   Target device: xilinx_kcu1500_dynamic_5_0
INFO: [VPL 60-1032] Extracting DSA to /home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/vivado/.local/dsa
INFO: [VPL 60-251]   Hardware accelerator integration...
ERROR: [VPL 60-399] vivado failed, please see log file for detail: '/home/sinitame/SDX/vadd/Emulation-HW/krnl_vadd/link/vivado/vivado.log'
ERROR: [VPL 60-806] Failed to finish platform linker
ERROR: [XOCC 60-398] vpl failed
ERROR: [XOCC 60-626] Kernel link failed to complete
ERROR: [XOCC 60-703] Failed to finish linking
WARNING: [XOCC 60-1140] Rule service exception in stopRuleCheckSession. Design Guidance report may not be produced. Exception: write: Broken pipe
makefile:82 : la recette pour la cible « krnl_vadd.xclbin » a échouée
make: *** [krnl_vadd.xclbin] Erreur 1

14:30:55 Build Finished (took 11m:59s.336ms)

When looking to the log file it seems that the error comes from libdpi with can't be linked. I attached the log file for more informations.

Same issue seems to be reported here #868024 :https://forums.xilinx.com/t5/SDAccel/Vivado-failed-to-link-libdpi-so/td-p/868024

I'm running SDx in a Debian (Strech) VM.

 

Any solution to solve this error ?

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
1,143 Views
Registered: ‎07-16-2008

回复: SDAccel 2018.2 fail to link libdpi.so

Jump to solution

Debian is not officially supported.

 

For Ubuntu, try to set environment variable CPATH to /usr/include/x86_64-linux-gnu.

You may also try to upgrade to 2018.2_XDF release, which should have fixed the issue.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

4 Replies
Observer skotti
Observer
1,420 Views
Registered: ‎06-18-2018

Re: SDAccel 2018.2 fail to link libdpi.so

Jump to solution

@meven, did you figured out what the issue is?

0 Kudos
Visitor nahmad16
Visitor
1,156 Views
Registered: ‎10-18-2018

Re: SDAccel 2018.2 fail to link libdpi.so

Jump to solution

I have the same error when compiling vadd in hw_emu. Anyone with a solution?

 

Thanks

0 Kudos
Xilinx Employee
Xilinx Employee
1,144 Views
Registered: ‎07-16-2008

回复: SDAccel 2018.2 fail to link libdpi.so

Jump to solution

Debian is not officially supported.

 

For Ubuntu, try to set environment variable CPATH to /usr/include/x86_64-linux-gnu.

You may also try to upgrade to 2018.2_XDF release, which should have fixed the issue.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Contributor
Contributor
1,124 Views
Registered: ‎05-11-2018

回复: SDAccel 2018.2 fail to link libdpi.so

Jump to solution

@graces thank you ,

"set environment variable CPATH" works 

0 Kudos