cancel
Showing results for 
Search instead for 
Did you mean: 
299 Views
Registered: ‎12-04-2019

Vitis Accelerated application xfopencv

Jump to solution

Hi,

I tried to create a test bench application on my own by referring Acceleration code in Zynq base trd 2019.2 in Vitis IDE, after creating custion acceleration platform from system.xsa from base vivado design and configutig petalinux sdk

After including necessary libraries , when I click build option, I get the following error

NOTE: I am trying to build accelerated opencv application

 

make -j4 incremental
/home/htic/Xilinx/2019.2/Vitis/2019.2/bin/v++ --target sw_emu --link --config common-config.ini --config binary_container_1-link.ini -D__SDSVHLS__ -DHLS_NO_XIL_FPO_LIB -o"binary_container_1.xclbin" binary_container_1.build/filter2d_accel.xo
Option Map File Used: '/home/htic/Xilinx/2019.2/Vitis/2019.2/data/vitis/vpp/optMap.xml'

****** v++ v2019.2 (64-bit)
**** SW Build 2708876 on Wed Nov 6 21:39:14 MST 2019
** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

INFO: [v++ 60-1306] Additional information associated with this v++ link can be found at:
Reports: /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/usm/Emulation-SW/binary_container_1.build/reports/link
Log files: /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/usm/Emulation-SW/binary_container_1.build/logs/link
Running Dispatch Server on port:41809
INFO: [v++ 60-1548] Creating build summary session with primary output /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/usm/Emulation-SW/binary_container_1.xclbin.link_summary, at Wed Feb 19 06:55:22 2020
INFO: [v++ 60-1316] Initiating connection to rulecheck server, at Wed Feb 19 06:55:22 2020
INFO: [v++ 60-895] Target platform: /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/zcu102USM/export/zcu102USM/zcu102USM.xpfm
INFO: [v++ 60-1578] This platform contains Xilinx Shell Archive '/home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/zcu102USM/export/zcu102USM/hw/system.xsa'
INFO: [v++ 60-629] Linking for software emulation target
INFO: [v++ 60-423] Target device: zcu102USM
INFO: [v++ 60-645] kernel flags are '-g -I /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/workspaces/ws_accel/work/usm/src -I /home/htic/TRD/rdf0421-zcu102-base-trd-2019-2/zcu102_base_trd/sw/zcu102_base_trd/a53_linux/inc/xfopencv -g'
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:43:‘__int_least8_t’ does not name a type; did you mean ‘__intptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:44:‘__int_least16_t’ does not name a type; did you mean ‘__int16_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:45:‘__int_least32_t’ does not name a type; did you mean ‘__int32_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:46:‘__int_least64_t’ does not name a type; did you mean ‘__int64_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:49:‘__uint_least8_t’ does not name a type; did you mean ‘__uint8_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:50:‘__uint_least16_t’ does not name a type; did you mean ‘__uint16_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:51:‘__uint_least32_t’ does not name a type; did you mean ‘__uint32_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:52:‘__uint_least64_t’ does not name a type; did you mean ‘__uint64_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:101:‘__intmax_t’ does not name a type; did you mean ‘__intptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/stdint.h:102:‘__uintmax_t’ does not name a type; did you mean ‘__uint64_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:58:‘::int_least8_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:59:‘::int_least16_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:60:‘::int_least32_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:61:‘::int_least64_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:63:‘::intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:76:‘::uint_least8_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:77:‘::uint_least16_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:78:‘::uint_least32_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:79:‘::uint_least64_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/cstdint:81:‘::uintmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:511:‘uint_least16_t’ does not name a type; did you mean ‘uint_fast16_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:584:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:587:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:592:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:592:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:595:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:599:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:608:‘uint_least32_t’ does not name a type; did you mean ‘uint_fast32_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:681:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:684:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:689:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:689:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:692:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/bits/char_traits.h:696:‘int_type’ does not name a type; did you mean ‘off_type’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/bits/cpu-set.h:42:conflicting declaration ‘typedef struct cpu_set_t cpu_set_t’
ERROR: [v++ 17-1309] Gcc: /usr/include/x86_64-linux-gnu/sys/types.h:197:conflicting declaration ‘typedef long int int64_t’
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/libc/usr/include/errno.h:37:conflicting declaration of ‘int* __errno_location()’ with ‘C’ linkage
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:55:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:57:‘intmax_t’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:57:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:57:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:57:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:60:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:‘intmax_t’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:62:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:65:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:65:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:67:‘_Qn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:67:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:67:‘_Qn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:67:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:67:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:70:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:71:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:71:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:72:‘intmax_t’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:72:‘_Pn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:72:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:72:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:72:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:75:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:76:‘_Qn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:76:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:77:‘intmax_t’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:77:‘_Qn’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:77:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:77:template argument 1 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:77:template argument 2 is invalid
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:86:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:86:‘intmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:90:‘uintmax_t’ does not name a type; did you mean ‘uintptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:92:‘uintmax_t’ does not name a type; did you mean ‘uintptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:93:‘uintmax_t’ does not name a type; did you mean ‘uintptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:94:‘uintmax_t’ does not name a type; did you mean ‘uintptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:95:‘uintmax_t’ does not name a type; did you mean ‘uintptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:97:‘__a1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:97:‘__b1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:99:‘__a0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:99:‘__b1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:99:‘__b0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:99:‘__a1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:99:‘__c’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:101:‘__b0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:101:‘__a0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:103:‘__a0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:103:‘__b1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:103:‘__b0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:103:‘__a1’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:103:‘__c’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:104:‘__b0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:104:‘__a0’ was not declared in this scope
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:108:‘intmax_t’ does not name a type; did you mean ‘intptr_t’?
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:113:‘uintmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:113:‘uintmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:113:‘uintmax_t’ has not been declared
ERROR: [v++ 17-1309] Gcc: /home/htic/Xilinx/2019.2/Vitis/2019.2/gnu/aarch64/lin/aarch64-linux/aarch64-linux-gnu/include/c++/8.2.0/ratio:113:‘uintmax_t’ has not been declared
INFO: [v++ 17-14] Message 'v++ 17-1309' appears 100 times and further instances of the messages will be disabled.
ERROR: [v++ 60-398] gcc failed
ERROR: [v++ 60-626] Kernel link failed to complete
ERROR: [v++ 60-703] Failed to finish linking

 

1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
43 Views
Registered: ‎07-16-2008

回复: Vitis Accelerated application xfopencv

Jump to solution

This issue is specific to Ubuntu, and this issue got fix in 2020.1 build.  In CentOS, you won’t see this issue. So please run the test case in CentOS machine as a workaround with 2019.2 build.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

5 Replies
Highlighted
Visitor
Visitor
227 Views
Registered: ‎02-11-2020

Re: Vitis Accelerated application xfopencv

Jump to solution

hi, I met the same question, did you solve this problem?

0 Kudos
Highlighted
Observer
Observer
157 Views
Registered: ‎08-28-2018

Re: Vitis Accelerated application xfopencv

Jump to solution

Hello,

I also have the same problem, did you manage to solve it?

Thanks in advance

0 Kudos
Highlighted
133 Views
Registered: ‎12-04-2019

Re: Vitis Accelerated application xfopencv

Jump to solution

no

0 Kudos
Highlighted
Participant
Participant
94 Views
Registered: ‎08-11-2019

回复: Vitis Accelerated application xfopencv

Jump to solution
Hi,I also met the same problem,did u solve it successfully. Thank U!
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
44 Views
Registered: ‎07-16-2008

回复: Vitis Accelerated application xfopencv

Jump to solution

This issue is specific to Ubuntu, and this issue got fix in 2020.1 build.  In CentOS, you won’t see this issue. So please run the test case in CentOS machine as a workaround with 2019.2 build.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post