We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Registered: ‎09-30-2019

Vitis IDE Debugger not working properly

I have this C++ kernel, it runs fine on Emulation-SW, and also runs fine with small datasets with Emulation-HW.

When the dataset grows slightly (just trying to sort 256words instead of 128), the IDE debugger in Emulation-HW behaves like this:

- it stops at kernel function start.

- does not show kernels variables (the watch windows says  "Failed to execute MI command: -var-create - * myVar  Error message from debugger back end is not available"

- subsequent "step" (F6) places the current instruction at random places in my C++ source code.

- the program does not terminate (both in "debug" and "run" mode)


I am sure that there-s something wrong in my program, but without a working Debugger it;s difficult to find out.
Again, in Emulation-SW it works fine with any dataset size.



Ubuntu 18.04

Xilinx Vitis IDE v2019.2 (64-bit)
SW Build 2708876 on Wed Nov 6 21:40:25 MST 2019


0 Kudos
3 Replies
Observer mabbi
Registered: ‎05-04-2018

Re: Vitis IDE Debugger not working properly

I have the same problem with Vitis 2019.2 on Ubuntu 18.04.

My HW contains a Microblaze programmed with a small C++ program.

Debugging worked with Vivado SDK 2019.1, but now in Vitis, the debugger behaves weird.

It's hard to figure out what is exactly going wrong.

Even the breakpoints are somehow mixed up. I think they are triggered in different lines I set them.

Stepping is not following the real program flow (e.g. the next step after a "return" leads to the next program line).


My theory is that the line to address mapping of Vitis contains an error.

But in addition, sometimes Resume (F8) does not work at all, I have to kill and restart the program.


Without debugging, fast SW development with Vitis is impossible.

Could someone provide a quickfix or workaround?




Using GDB instead of the default chosen Xilinx debugger (Launch on HW (Single Application Debug (GDB))) solves all of these issues.

Debugging works without any problems.


Unfortunately I had to switch to a  64-bit Microblaze, which seems to be unsupported by GDB:


Error in final launch sequence
Failed to execute MI command:
Error message from debugger back end:
The program is not being run.
The program is not being run.

Again, Xilinx debugger starts but shows the same problems as before.

0 Kudos
Observer mabbi
Registered: ‎05-04-2018

Re: Vitis IDE Debugger not working properly

After extending the program, GDB shows similar behavior even for 32 bit microblaze.

Setting breakpoints in Vitis results in a yellow triangle saying: "breakpoint installation failed: interrupt failed".

Stepping through the program (with F5) works up to a certain point.

After this point, program execution cannot be stopped or even cancelled anymore.


Since nobody has answered so far: Can anyone tell me how to open an official ticket for this problem?


I already tried to port my project back to vivado 2019.1 and xilinx SDK, but the tcl script is failing with errors of unknown parameters.

Is there a trick?

0 Kudos
Registered: ‎07-22-2018

Re: Vitis IDE Debugger not working properly

I'm having similar issues trying to use the Vitis debugger on a 32-bit microblaze.  It will not allow me to step through the code using either launch method (TCF or GDB).  Did you ever figure out the issue?

Thanks for any help.

0 Kudos