UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
317 Views
Registered: ‎11-18-2019

Vitis not creating platform from custom XSA File

Jump to solution

I've got a custom Artix7 Board running a microblaze architecutre that I am trying to get imported into Vitis. 

When i try and load my XSA into the Platform Project, I just get blank options for the OS and the Processor, almost like the XSA file Vivado is creating is no good : 

error1.pngerror2.png 

I've also tried just loading my XSA file directly into a blank Application Software Project, but Vitis bugs out on me : 

error3.PNG

 

Anybody point me in the right direction? 

0 Kudos
1 Solution

Accepted Solutions
272 Views
Registered: ‎11-18-2019

Re: Vitis not creating platform from custom XSA File

Jump to solution

After messing with this more, I've figure out the issue. Vitis will only create the platform if the workspace is inside the vivado project dicretory. I made a [project_name].vitis folder, and set that as my workspace, and it worked. This is simular to the old .sdk folder that would get created. 

View solution in original post

0 Kudos
1 Reply
273 Views
Registered: ‎11-18-2019

Re: Vitis not creating platform from custom XSA File

Jump to solution

After messing with this more, I've figure out the issue. Vitis will only create the platform if the workspace is inside the vivado project dicretory. I made a [project_name].vitis folder, and set that as my workspace, and it worked. This is simular to the old .sdk folder that would get created. 

View solution in original post

0 Kudos