UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant l502418608
Participant
364 Views
Registered: ‎10-31-2018

XRT install problem

Jump to solution

I installed the SDAccel 2018.2,But it does't has the XRT,So I have a question,is it the reason that I can't see any devices?If it is,How can I add the apporiate version XRT?

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
254 Views
Registered: ‎07-17-2018

Re: XRT install problem

Jump to solution

You have to make the OS find the FPGA device in advance, then install the driver.

From the lspci -vd 10ee: print, it seems the OS did not detect the two physical functions in your system

after program the FPGA, please try to power cycle you machine. then use lspci to check again

 

View solution in original post

9 Replies
Moderator
Moderator
308 Views
Registered: ‎11-04-2010

Re: XRT install problem

Jump to solution

Please download the XRT and DSA on Xilinx website.

https://www.xilinx.com/products/boards-and-kits/alveo/u200.html#gettingStarted

Select "Getting Started" and refer to UG1301.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant l502418608
Participant
296 Views
Registered: ‎10-31-2018

Re: XRT install problem

Jump to solution

My Board is KCU1500,Not the U200,and KCU1500 don't have the "Getting Started", Meantime UG1260 don't mention XRT

0 Kudos
Moderator
Moderator
288 Views
Registered: ‎11-04-2010

Re: XRT install problem

Jump to solution

Hi, @l502418608 ,

Have you downloaded KCU1500 5.0 Platform (ZIP - 495.21 MB)?

https://www.xilinx.com/registration/sign-in.html?oamProtectedResource=wh%3Dwww.xilinx.com%20wu%3D%2Fmember%2Fforms%2Fdownload%2Fxef.html%3Ffilename%3Dplatform_xilinx_kcu1500_dynamic_5_0__20180411.zip%20wo%3D1%20rh%3Dhttps%3A%2F%2Fwww.xilinx.com%20ru%...

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant l502418608
Participant
278 Views
Registered: ‎10-31-2018

Re: XRT install problem

Jump to solution

Of course I have downloaded the  KCU1500 5.0 Platform,and I also ./xbinst it ,and this is my questions:

XRT Problem
1.If I don't install the XRT,Can I see my device?

2.Why I use xbsak scan I can't see the information about xclmgmt and xocl,What's the problem?

3.Now I installed the XRT,But the problem is as same as the problem2,what should I do?

It should be:

V7%JX}BI$1$)A77(69{_)KP.png

But now it is:

V7%JX}BI$1$)A77(69{_)KP_副本.png

0 Kudos
Xilinx Employee
Xilinx Employee
271 Views
Registered: ‎07-17-2018

Re: XRT install problem

Jump to solution

1.If I don't install the XRT,Can I see my device?

    you can use lspci -vvd 10ee: to check if the devices are detacted and if the driver is loaded

2.Why I use xbsak scan I can't see the information about xclmgmt and xocl,What's the problem?

possible reason is he driver did not be installed properly.

 

please try "xbsak list" , if you can find the device or not

Did you meet any error when build and install the mgmt. driver.

Please try  dmesg  after you build and install the driver, watch if there are any error report

 

 

Participant l502418608
Participant
260 Views
Registered: ‎10-31-2018

Re: XRT install problem

Jump to solution

How to install mgmt.driver?I can't see any device using lspci -d 10ee:,I just run the ./xbinst platform.

Screenshot from 2019-09-03 15-04-58.png

 

It's no error When I run the ./install -f yes.like this:Screenshot from 2019-09-03 15-02-05.png

 

I also reflash the board with the .mcs files ,like this:

Screenshot from 2019-09-03 15-20-27.png

But it doesn't works!

0 Kudos
Xilinx Employee
Xilinx Employee
255 Views
Registered: ‎07-17-2018

Re: XRT install problem

Jump to solution

You have to make the OS find the FPGA device in advance, then install the driver.

From the lspci -vd 10ee: print, it seems the OS did not detect the two physical functions in your system

after program the FPGA, please try to power cycle you machine. then use lspci to check again

 

View solution in original post

Participant l502418608
Participant
233 Views
Registered: ‎10-31-2018

Re: XRT install problem

Jump to solution

I will try again ,Thanks.And I have a problem,Is it using two mcs files of primary.mcs and secondary.mcs to burn into mt25qu512*1*2*4*8 flash? Is this the process of completing the program FPGA?

0 Kudos
Participant l502418608
Participant
201 Views
Registered: ‎10-31-2018

Re: XRT install problem

Jump to solution

Now I use the lspci can see my device like this:01:00.0 Memory controller:Xilinx Corporation Device 8038

 

But I use ./xbsak flash scan still has no device,what's the problem?How to install mgmt.driver?I think I had already installed it like this :IMG_20190908_202235.jpg

I need your help,thanks!

0 Kudos