cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,863 Views
Registered: ‎11-08-2017

reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Hi, All,

 

I follow the steps http://www.wiki.xilinx.com/reVISION+Getting+Started+Guide+2017.2 to do the demo on zcu102 for reVISION, but got the error ERROR: vlib_init failed when type in of2.elf . I have refer https://forums.xilinx.com/xlnx/board/crawl_message?board.id=ultrascale&message.id=4618 and type in of2.elf -s 1 -m 2 -d 1 but stiil failed. Who can help me?

 

Thanks very much

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
2,547 Views
Registered: ‎11-08-2017

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Hi, Jose,

 

after I changed the command from "stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 -filter-sv-cam-params /media/card/SN15284.conf" to "stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 --filter-sv-cam-params /media/card/SN15284.conf", it works well. Thanks a lot.

View solution in original post

0 Kudos
7 Replies
Highlighted
Visitor
Visitor
1,858 Views
Registered: ‎11-08-2017

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

I use the hardware is HW-Z1-ZCU102 REVISION 1.1

0 Kudos
Highlighted
Scholar
Scholar
1,821 Views
Registered: ‎02-27-2008

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Is this a copy of the SD card image?

 

Check the pre-built image SD copies on the SD card.

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
1,807 Views
Registered: ‎11-08-2017

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Dear ,

 

Yes, I just copy the demo from the ZCU102 Production Silicon reVISION Package: Includes SDSoC platform, design examples, and pre-built SD card images

 

And there is another one ZCU102 ES2 Silicon reVISION Package: Includes SDSoC platform, design examples, and pre-built SD card images. May I know how to seperate "ZCU102 Production Silicon reVISION Package" and "ZCU102 ES2 Silicon reVISION Package"? Is that I should use ZCU102 ES2 Silicon reVISION Package?

 

Thanks a lot.

0 Kudos
Highlighted
Scholar
Scholar
1,776 Views
Registered: ‎02-27-2008

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Check what identifies when you connect the JTAG-USB and bring up hardware manager.

 

Or, look at the shipment papers for your board.

Depending on how old it is, it is ES1, ES2, or production.

 

You do require the correct image for the board (ES2 will not work for production, and vice-versa).

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
1,752 Views
Registered: ‎11-08-2017

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Hi, local service told me this is production on my hand. So I should use ZCU102 Production Silicon reVISION Package.  But it still error when I type in of2.elf. And I try to run anther demo Stereo Vision still failed. I have connected ZED for capture and monitor 1920x1080. When booting I found the following message:

 

[   15.833184] usb 2-1: Manufacturer: Leopard
[   15.844805] uvcvideo: Found UVC 1.00 device ZED (2b03:f580)
[   15.853559] uvcvideo 2-1:1.0: Entity type for entity ZED was not initialized!
[   15.860640] uvcvideo 2-1:1.0: Entity type for entity ZED was not initialized!
[   15.867748] uvcvideo 2-1:1.0: Entity type for entity Camera 1 was not initialized!

 

Then:

 

Starting Telephony daemon
Starting tcf-agent: OK

Setting console loglevel to 0 ...
/bin/autologin: line 1: -e: command not found
root@zcu102_base_trd:~# ^C

 

when I write command: stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 -filter-sv-cam-params /media/card/SN15284.conf

the message out is:


root@zcu102_base_trd:~# stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 -filter-sv-cam-params /media/card/SN15284.conf
Invalid frame rate 'ilter-sv-cam-params'
root@zcu102_base_trd:~#

 

So, Can you guid me how to run a success demo? thanks a lot.

0 Kudos
Highlighted
Scholar
Scholar
1,744 Views
Registered: ‎02-27-2008

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

OK,

 

I use

 

of2.elf -o 1920x1080

 

after I login.

 

My display is on the DP port.  Both display and my Leopard MIPI camera support 1920x1080 (they must match in the of demo).

 

From your log, it does not seem to find the camera?

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
2,548 Views
Registered: ‎11-08-2017

Re: reVISION demo on ZCU102 ERROR: vlib_init failed: connector supports no mode

Jump to solution

Hi, Jose,

 

after I changed the command from "stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 -filter-sv-cam-params /media/card/SN15284.conf" to "stv.elf -s 2 -m 2 -d 1 -i 3840x1080 -o 1920x1080 --filter-sv-cam-params /media/card/SN15284.conf", it works well. Thanks a lot.

View solution in original post

0 Kudos