UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sioan
Visitor
1,878 Views
Registered: ‎10-11-2017

trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

(thank you in advance for all your help)

 

#############################################

problem context:

I just got a kcu1500 and I'm going through the "ug1234-ref-design-dev-board-accel-kcu1500.pdf" manual.

 

The SDx version of vivado 2017.2 has been installed, and the license "Xilinx.lic" file loaded

 

The tcl scripts in chapter five work and I can synthesize and implement the "reference design file" xilinx_kcu1500_4ddr-xpr_4_0.xpr project without any errors.

(the xilinx_kcu1500_4ddr-xpr_4_0.dsa file is generated in these steps )

#############################################

problem description:

I run into problem using the xbinst utility (step 2 in chapter six, page 45 of the  "ug1234-ref-design-dev-board-accel-kcu1500.pdf" manual.)

 

the command I run is 

sudo xbinst -f <path to xilinx_kcu1500_4ddr-xpr_4_0.xpfm file OR xilinx:kcu1500:4ddr-xpr:4.0> -d .

 

and the error messages are

 

ERROR: [XBINST 60-705] No device was found that matches 'xilinx_kcu1500_4ddr-xpr_4_0.xpfm'. The supported devices are:

ERROR: [XBINST 60-587] Failed to add a device: specified platform xilinx_kcu1500_4ddr-xpr_4_0/xilinx_kcu1500_4ddr-xpr_4_0.xpfm is not found

#######################################################

 

The solutions proposed for similar problems (see forum links below) haven't yet solved this problem.

 
running  "xocc --list_xdevices" does give a list of supported devices.
 
my current guess is that it's a licensing issue, or that I'm xbinst is a much bigger utility than I realize.  
Thank you, again , in advance for your help
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
2,719 Views
Registered: ‎04-24-2013

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

Hi @sioan

 

I have seen this issue previously and it was down to permissions.

 

If you type xbinst help it should list the devices that you can configure and the list of command options.
You need to build a string similar to the following for your device.

xbinst -f xilinx:xil-accel-rd-ku115:4ddr-xpr:4.0 -d .

where -f is the platform and -d is the destination directory. When this is run you should now have a xbinst directory.

Change directory to the xbinst directory and check the contents, you need to run the install.sh script with sudo permissions e.g.

sudo ./install.sh

The sudo command is important.

When it is finished you will see more files in the directory. 
If you use the more command on setup.sh you can see that it sets and unsets certain variables.
It is important to check that the XCL_EMULATION_MODE is unset, then run source setup.sh

source setup.sh

The test directory will let you check the connection, so you can now run:

./test/verify.exe ./test/verify.xclbin

UG1023 (v2017.2) August 16, 2017, Appendix C, page 88 covers the xbinst command

 

Let me know if this helps.

Best Regards
Aidan

 

 

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

View solution in original post

5 Replies
Moderator
Moderator
2,720 Views
Registered: ‎04-24-2013

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

Hi @sioan

 

I have seen this issue previously and it was down to permissions.

 

If you type xbinst help it should list the devices that you can configure and the list of command options.
You need to build a string similar to the following for your device.

xbinst -f xilinx:xil-accel-rd-ku115:4ddr-xpr:4.0 -d .

where -f is the platform and -d is the destination directory. When this is run you should now have a xbinst directory.

Change directory to the xbinst directory and check the contents, you need to run the install.sh script with sudo permissions e.g.

sudo ./install.sh

The sudo command is important.

When it is finished you will see more files in the directory. 
If you use the more command on setup.sh you can see that it sets and unsets certain variables.
It is important to check that the XCL_EMULATION_MODE is unset, then run source setup.sh

source setup.sh

The test directory will let you check the connection, so you can now run:

./test/verify.exe ./test/verify.xclbin

UG1023 (v2017.2) August 16, 2017, Appendix C, page 88 covers the xbinst command

 

Let me know if this helps.

Best Regards
Aidan

 

 

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

View solution in original post

Visitor sioan
Visitor
1,771 Views
Registered: ‎10-11-2017

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

Hi Aidan,

 

Thank you for the quick response.

 

the xbinst directory is empty.  Variations of the xbinst command are copied below.

(output from lspci -v is included too)

 

################################################################

sudo xbinst -f <path to xpfm>/xilinx_kcu1500_4ddr-xpr_4_0.xpfm -d .

****** xbinst v2017.2_sdx (64-bit)
**** SW Build 1972098 on Wed Aug 23 11:34:38 MDT 2017
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

ERROR: [XBINST 60-705] No device was found that matches '<path to xpfm>xilinx_kcu1500_4ddr-xpr_4_0.xpfm'. The supported devices are:

ERROR: [XBINST 60-587] Failed to add a device: specified platform <path to xpfm>/xilinx_kcu1500_4ddr-xpr_4_0.xpfm is not found

 

 

sudo xbinst -f xilinx:kcu1500:4ddr-xpr:4.0 -d .

****** xbinst v2017.2_sdx (64-bit)
**** SW Build 1972098 on Wed Aug 23 11:34:38 MDT 2017
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

ERROR: [XBINST 60-705] No device was found that matches 'xilinx:kcu1500:4ddr-xpr:4.0'. The supported devices are:

ERROR: [XBINST 60-587] Failed to add a device: specified platform xilinx:kcu1500:4ddr-xpr:4.0 is not found

 

sudo xbinst -f xilinx_kcu1500_4ddr-xpr_4_0 -d .

****** xbinst v2017.2_sdx (64-bit)
**** SW Build 1972098 on Wed Aug 23 11:34:38 MDT 2017
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

ERROR: [XBINST 60-705] No device was found that matches 'xilinx_kcu1500_4ddr-xpr_4_0'. The supported devices are:

ERROR: [XBINST 60-587] Failed to add a device: specified platform xilinx_kcu1500_4ddr-xpr_4_0 is not found

 

 

#######################################################

 

sudo lspci -v

02:00.0 Serial controller: Xilinx Corporation Device 8638 (prog-if 01 [16450])
Subsystem: Xilinx Corporation Device 4434
Flags: fast devsel, IRQ 24
Memory at f7800000 (32-bit, non-prefetchable) [size=4M]
Memory at f7ef0000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [80] Power Management version 3
Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [c0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [300] #19
Capabilities: [340] Vendor Specific Information: ID=0001 Rev=0 Len=02c <?>

0 Kudos
Visitor sioan
Visitor
1,762 Views
Registered: ‎10-11-2017

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution
(just got xbinst to work. Didn't use sudo and passed xpfm file location to -f flag.)
0 Kudos
Visitor sioan
Visitor
1,750 Views
Registered: ‎10-11-2017

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

progressing slow but surely!

now having error from 

 

./test/verify.exe ./test/verify.xclbin

 

see below

Linux:2.6.32-696.3.1.el6.x86_64:#1 SMP Thu Apr 20 11:30:02 EDT 2017:x86_64
---
XILINX_OPENCL="<path to rdf>/ug1234-ref-design-dev-board-accel-kcu1500/reference_design/xbinst"
LD_LIBRARY_PATH="<path to rdf>//ug1234-ref-design-dev-board-accel-kcu1500/reference_design/xbinst/runtime/lib/x86_64:<path to rdf>/ug1234-ref-design-dev-board-accel-kcu1500/reference_design/xbinst/runtime/lib/x86_64:"
---
ERROR: No devices found
Error: Failed to find an OpenCL platform!
Test failed

0 Kudos
Moderator
Moderator
1,710 Views
Registered: ‎04-24-2013

Re: trouble with xbinst instructions from ug1234-ref-design-dev-board-accel-kcu1500

Jump to solution

Hi @sioan,

 

I don't know if you have shortened the paths, but in them the <path to rdf> should be the actual path to where the files are and not <path to rdf>. Also in the LD_LIBRARY_PATH you have a double // (forward slash) i.e.

 

LD_LIBRARY_PATH="<path to rdf>//ug1234-ref-design-dev-board-accel-kcu1500/reference_design/xbinst/runtime/lib/x86_64:<path to rdf>/ug1234-ref-design-dev-board-accel-kcu1500/reference_design/xbinst/runtime/lib/x86_64:"

 

Best Regards
Aidan

 

 

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------

------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if this answered your question
Give Kudos to a post which you think is helpful and may help other users
------------------------------------------------------------------------------------------------------------------
0 Kudos