UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
598 Views
Registered: ‎03-27-2008

Chipscope in ise 14.7 - ERROR:TSDatabase:19

Jump to solution

I have a project which works fine until I try to use Chipscope.

During mapping, I get errors:


ERROR:TSDatabase:19 - Processing TIMESPEC definition
TS_D2_TO_T2=FROM:D2_CLK:TO:FFS:TIG:
No TNM, TPSYNC or user group named "D2_CLK" is defined.
ERROR:TSDatabase:19 - Processing TIMESPEC definition
TS_J2_TO_D2=FROM:FFS:TO:D2_CLK:TIG:
No TNM, TPSYNC or user group named "D2_CLK" is defined.
ERROR:TSDatabase:19 - Processing TIMESPEC definition
TS_J3_TO_D2=FROM:FFS:TO:D2_CLK:TIG:
No TNM, TPSYNC or user group named "D2_CLK" is defined.
ERROR:TSDatabase:19 - Processing TIMESPEC definition
TS_J4_TO_D2=FROM:FFS:TO:D2_CLK:TIG:
No TNM, TPSYNC or user group named "D2_CLK" is defined.
INTERNAL_ERROR:Pack:pkibangm.c:2584:1.87 - 4 timespec errors found

 

I managed to find this which has the exact errors:

https://www.xilinx.com/support/answers/43548.html

 

But, the solution didn't work, the alternative workaround means nothing to me so I currently don't know how to try that.

 

Can anyone help?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
583 Views
Registered: ‎06-25-2014

Re: Chipscope in ise 14.7 - ERROR:TSDatabase:19

Jump to solution

This post has detail on the alternative solution which is setting an environment variable:

 

 

https://forums.xilinx.com/t5/Design-Tools-Others/ChipScope-Clock-Problems/m-p/428900?device-view=desktop

2 Replies
Highlighted
Explorer
Explorer
584 Views
Registered: ‎06-25-2014

Re: Chipscope in ise 14.7 - ERROR:TSDatabase:19

Jump to solution

This post has detail on the alternative solution which is setting an environment variable:

 

 

https://forums.xilinx.com/t5/Design-Tools-Others/ChipScope-Clock-Problems/m-p/428900?device-view=desktop

Adventurer
Adventurer
573 Views
Registered: ‎03-27-2008

Re: Chipscope in ise 14.7 - ERROR:TSDatabase:19

Jump to solution

Ah, thank-you!

It would have been useful if the AR# actually stated it was a system/environment variable and not something that goes into one of the project files somewhere....

 

0 Kudos