cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
10,681 Views
Registered: ‎03-14-2012

Error: Failed to detect cable in Chipscope pro...

Hello,

 

I'm having difficulty getting Chipscope Pro to analyze my design.  My system is a MacBook Pro, running VMWare Fusion, Version 6.0.5. In VMWare, I'm running Microsoft Windows 7, 32 bit.  ISE version 14.4, Chipscope version 14.4 P.49d

 

I can program the device, but I can't analyze the design.  I get the following errors when I try to initialize the JTAG chain:

 

COMMAND: open_cable
INFO: Started ChipScope host (localhost:50001)
INFO: Successfully opened connection to server: localhost:50001 (localhost/127.0.0.1)
ERROR: INTERNAL_ERROR:Portability:basutencodeimp.c:229:1.24 - Number of bytes peeked does not match number of bytes requested. Corrupted file?
INFO: Trying to open Xilinx Platform USB Cable on port USB2
ERROR: INTERNAL_ERROR:Portability:basutencodeimp.c:229:1.24 - Number of bytes peeked does not match number of bytes requested. Corrupted file?
INFO: Trying to open Digilent USB JTAG Cable on port (no port specified)
INFO: Trying to open Xilinx Parallel Cable on port LPT1
INFO: Trying to open Xilinx Parallel Cable on port LPT2
INFO: Trying to open Xilinx Parallel Cable on port LPT3
INFO: Trying to open Xilinx Parallel Cable on port LPT4
ERROR: Failed to detect cable.
Try to open a specific cable from the 'JTAG Chain' menu.

 

I really want to be able to use the software while running in VMWare.  Has anyone had this same issue? Is there a work-around for this?  Do I have to install Windows 7 stand-alone, and not use VMWare?

 

Thanks in advance for you help,

 

Todd Moore

University of Illinois

0 Kudos
4 Replies
Highlighted
Moderator
Moderator
10,671 Views
Registered: ‎01-16-2013

Re: Error: Failed to detect cable in Chipscope pro...

0 Kudos
Highlighted
Observer
Observer
10,657 Views
Registered: ‎03-14-2012

Re: Error: Failed to detect cable in Chipscope pro...

Thanks yashp for your help.

 

Here's the steps that I tried, and my results:

 

1. I turned off UAC. I also set C:\Xilinx\14.4\ISE_DS\ISE\bin\nt\analyzer.exe to be ran as administrator.  I got the same errors as before.

 

2. I then set C:\Xilinx\14.4\ISE_DS\ISE\bin\nt\unwrapped\analyzer.exe to be ran as administrator. I continue to get the same errors as before.

 

3. I then set C:\Xilinx\14.4\ISE_DS\ISE\bin\nt\ise.exe to be ran as administrator.  The thinking here is that I launch chipscope (analyzer.exe) from within the ISE GUI, so maybe running ISE as admin could fix the error.  I continue to get the same errors as before, even with this fix.

 

 I really need to be able to run Xilinx on my laptop running VMWare/Win7!! Do you or anyone else have any other recommendations?

 

Also, as a side note, the link in AR#32912 going to Microsoft (http://technet2.microsoft.com/WindowsVista/en/library/0d75f774-8514-4c9e-ac08-4c21f5c6c2d91033.mspx?mfr=true)

showing how to turn off UAC is broken.  We turn UAC off by default on our engineering workstations, so I already knew how to do it anyway.  You can just use your favorite search engin to find how to turn off UAC.

 

Thanks again for all your help,

 

Todd Moore

University of Illinois

0 Kudos
Highlighted
Newbie
Newbie
8,560 Views
Registered: ‎01-18-2016

Re: Error: Failed to detect cable in Chipscope pro...

I am also facing the same issue and tried the same steps as done by Moore but still facing the issue

Is there anyone who faced the same and tried something else to recover from this.

 

Regards,

Binay

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,527 Views
Registered: ‎07-21-2014

Re: Error: Failed to detect cable in Chipscope pro...

Hi,

Most of the time this issue was also seen previously when there is a corrupted ISE download file. Can you please check the MD5SUM value of downloaded zip with the one on webpage?

Also, try using ISE 14.7 and see if you get any improvements on this.

-Shreyas
----------------------------------------------------------------------------------------------
Try to search answer for your issue in forums or xilinx user guides before you post a new thread.

Kindly note- Please mark the Answer as "Accept as solution" if information provided solves your query.
Give Kudos (star provided in right) to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos