UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor noopur
Visitor
10,029 Views
Registered: ‎06-04-2014

Hardware cosim on ZYBO using JTAG

Hello,

 

I wanted to carry out HW Cosim using System Generator 14.6. It does fulfill the 3 criteria given on page 199 of Xilinx
System Generator for DSP Version 9.1 user guide (sysgen_ug)

 

Since there is no in- built board support package for ZYBO in system generator (like ZC702) I tried creating one using SBDBuilder. However while creating New Compilation Target; I am unable to find Zynq as target-able device.

 

Does this mean HW Cosim is only possible using ZC702 & not with ZYBO Zynq Z-7010 at the moment?

Please guide.

 

Note:- Tried with Matlab R2013a as well as R2010a.

 

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
10,022 Views
Registered: ‎02-06-2013

Re: Hardware cosim on ZYBO using JTAG

Hi

 

This is a known issue where 7 series devices are not shown for SBDBuilder.

 

Use ISE 14.3 as a work around to create the new Board Descriptions and which can be bought in to ISE14.4 or later versions.
 
You can alsodirectly create the Board support package Files by editing the template files present in the sysgen/hwcosim/jtag/templates
directory to suit your board requirement.
 
See UG640 Supporting New Platforms through JTAG Hardware section for more details on the required file modifications and the process to do that.
Regards,

Satish

--------------------------------------------------​--------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
0 Kudos
Visitor noopur
Visitor
10,005 Views
Registered: ‎06-04-2014

Re: Hardware cosim on ZYBO using JTAG

Using 14.2, I could create board support file. Thanks for the guidance.

 

It creates JTAG Cosim model with all files except .bit file, so I used ISE 14.7 to generate .bit file (from CW project created in Simulink).

 

While running cosim following error was found

Could not find a ARM device on the board. Please check if the target is in:

1. Split JTAG mode - No operations are possible with ARM DAP

2. Non Jtag bootmode - Bootrom may need time to enable DAP. Please try again

Error occurred during "Simulation Initialization".

 

To resolve this I have already tried AR17966 and verified with MATLAB 2010a/2013a- ISE 14.6 and MATLAB 2013a -ISE 14.7 but both of them still gives the same error.

 

Also tried:- http://forums.xilinx.com/t5/Embedded-Processor-System-Design/Zynq-not-detecting-ARM-system/td-p/331561

 

After this I downloaded the program through iMPACT and checked skip device configuration in JTAG-Cosim model. This somehow solved the above error but the scope output from hwcosim is 0, whereas the other scope output directly from simulink simulator (without cosim model) shows correct result.

 

Please help to get the correct scope results from hw-cosim. Thanks

 

 

 

0 Kudos