cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
9,223 Views
Registered: ‎02-05-2012

Impact stops running

We are using a Digilent USB pod to program a Spartan 6 LX45T-csg324.  We have two setups, one running Windows 7 64-bit Home Premium, the other running Windows 7 64-bit Professional.

 

We have no problems with the USB driver, and, if Impact runs, it properly connects and programs the device.

 

However, we have serious problems with Impact not running at all.  When we attempt to run Impact, we get a dialog box reporting that "Impact has stopped working".  This appears to be associated with Impact loading the last project file.  On one machine we solved the issue by running a previously installed version of Impact (13.2 vs 13.3) and never saving a project.  That system still works.

 

However, on another system (Windows 7 Professional, running 13.2), apparently something is now corrupted such that we can no longer run Impact at all.  We have tried reinstalling everything and still get the error.  

 

We're now completely helpless at one site because of this problem. 

 

 I haven't been able to find anything like this problem after doing a lot of searching.  We have also looked for alternative programs to use.  The Digilent Adept software doesn't fully recognize the LX45T device, and I have found no other programming solutions.

 

Any one have any suggestions? 

0 Kudos
11 Replies
Highlighted
Professor
Professor
9,213 Views
Registered: ‎08-14-2007

When you first run Impact after a new install, you have the option of always

loading the last project.  I generally uncheck that and also check the

don't ask again box, so it always comes up asking me what to do.  On the

system that doesn't run, it is possible that these settings are stored in

the Windows registry, and if you could find the right keys, you could

do the equivalent of unchecking the box.  It is also likely that the registry

keys are not automatically cleaned out if you uninstall and re-install

the Impact ("Lab Tools") software.

 

You could search the WIndows registry using regedit and looking for

"impact" to find appropriate keys.  Still it may be difficult to decipher

the values that make Impact run the way you want, unless you have

another system handy that has the correct settings to compare against.

 

-- Gabor

-- Gabor
0 Kudos
Highlighted
Visitor
Visitor
9,204 Views
Registered: ‎02-05-2012

I have actually determined that the failure is reproducible and is caused by saving a project in Impact.  Once a project has been saved, if Impact attempts to open the project, it crashes.

 

I'm not sure, but I don't think it is just the .ipf file that causes this, but the entire directory.  At least, to fix our site, it was required to removed the entire directory where the project resided.  Once that is done (I renamed it), then Impact again would run properly.  If I then attempted to open this project, Impact would crash.

 

We have seen this on Windows 7 64-bit, both Professional and Home Premium.

 

I have filed a web case, but no resolution yet.

0 Kudos
Highlighted
Teacher
Teacher
9,202 Views
Registered: ‎09-09-2010

Was there a space in the directory name?

------------------------------------------
"If it don't work in simulation, it won't work on the board."
0 Kudos
Highlighted
Visitor
Visitor
9,201 Views
Registered: ‎02-05-2012

No, no spaces in the directory or file names.

0 Kudos
Highlighted
Professor
Professor
9,198 Views
Registered: ‎08-14-2007

When you have Impact running, go to Edit --> Preferences

and select the "Project Settings Control" tab.  Uncheck both boxes:

 

 

-- Gabor

-- Gabor
0 Kudos
Highlighted
Visitor
Visitor
9,190 Views
Registered: ‎02-05-2012

We've done that.  Of course, it helps to avoid the problem, but you still have to be very careful not to say yes when exiting.  Otherwise, kaboom!

 

And, this is a terrible problem for the novice.  This is how we found the severity of the problem.  The software team, remote from the hardware team and trying to use Impact, which they assumed would work.  

 

Bad assumption.

0 Kudos
Highlighted
Professor
Professor
9,185 Views
Registered: ‎08-14-2007

Well, obviously it's not a real fix, but I thought that it's a more convenient work-around

than deleting the project folder after each session.  Let us know when you get some

response on the webcase.

 

-- Gabor

-- Gabor
0 Kudos
Highlighted
Visitor
Visitor
9,183 Views
Registered: ‎02-05-2012

The response on the web case was "We have seen the problem before.  It will be fixed in the next release."

 

I must admit to a certain frustration with the reponse.  There was much discussion about irrelevant details, given that they knew of the problem.  There was also no discussion or suggestion of the helpful but incomplete workaround both you and I discussed.  I had given them a project directory that always caused the crash, but had to prompt them to admit they tried it and it failed for them as well.

 

I wonder if other, better workarounds exist.  For example, how about running from the command line?  I have thought of this, but haven't yet tried it--too much else to do at this point.  

 

Also, is the problem specific to Windows 7?  We never saw it on XP, but then we also never used a Digilent cable on XP.  Is it specific to the Digilent cable?

 

Enough.  I can make it work, and I need to work on my own bugs . . .

0 Kudos
Highlighted
Visitor
Visitor
8,720 Views
Registered: ‎01-12-2010

I was running version 13.4... started the same issue last week. 

Completely uninstalled Xilinx and reinstalled version 14.4.... same thing. 

 

Over the years, I have seen several issues where xilinx says it "will be fiixed with the next version"  yet I am still plagued by several of same issues.

 

0 Kudos
Highlighted
Observer
Observer
1,559 Views
Registered: ‎09-13-2012

Hi,

this is quite an old thread, I know, but I was having the same troubles and found a very simple solution, which I wanted to share.

 

The problem was in "Impact LabTools 14.7", when you check the "automatically load last project" setting, it was crashing all the time with "_pn.exe stopped working". Even a re-install didn't fix it.

 

The solution is to fix the setting in the windows registry, where Xilinx stores these settings and actually don't change it with a re-install. The key is pretty easy to find:

COMPUTER - HKEY_CURRENT_USER - Software - Xilinx - Lab Tools - 14.7 - Impact - GENERAL_OPTIONS - AUTO_LOAD_PROJECT

Change the value from "true" to "false" and you're done.

 

Greetings,

Highlighted
Xilinx Employee
Xilinx Employee
1,553 Views
Registered: ‎10-24-2013

Hi @woko

 

Thanks for your contribution and Iam sure that this will help other users.

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos