UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant space_boy
Participant
10,665 Views
Registered: ‎11-21-2007

Linux USB JTAG Cable Driver for Impact

I've read much on this topic here and elsewhere in various guises, but I remain confused on some things, not to mention some of what I've read is out of date w.r.t. s/w versions, etc. I've been frustrated ona previous attempt to get things going, but am now starting with a fresh OS installation and hope to resolve compatability issues up front.

 

So, I'm running Ubuntu 14.04 and have downloaded but not yet installed Xilinx LabTools 14.7. I also have the infamous usb-driver-HEAD.tgz but have not yet installed it.

 

First, my OS is 64-bit. In spite of that, do i need to install the 32-bit version of LabTools to be compatible with the usb-driver? From what I've read, it doesn't sound as thuogh there is a 64-bit version of the driver. Is that true/

 

Is there a "canonical" list of installation steps to get these things to work together?

 

Thanks!

Ron

 

 

 

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
10,650 Views
Registered: ‎04-16-2012

Re: Linux USB JTAG Cable Driver for Impact

Hello Ron,

 

Ubuntu is an unsupported OS with Xilinx ISE tools.

 

However, here are few forum links where customers are suceeded in installing the cable drivers on unbuntu OS:

 

http://forums.xilinx.com/t5/Configuration/installing-platform-cable-USB-II-ubuntu/m-p/66729#M324

http://rmdir.de/~michael/xilinx/

http://forums.xilinx.com/t5/General-Technical-Discussion/Problem-with-PlanAHead-iMPACT-and-Ubuntu-14/td-p/522739

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Visitor yankele
Visitor
10,573 Views
Registered: ‎12-01-2008

Re: Linux USB JTAG Cable Driver for Impact

I use one Spartan 3A and two Spartan 3AN in three data acquisition systems, since several years and no problems.

I had to upgrade to Fedora 20 kernel 3.17.2-200 because the very large applications using the FPGA's have been improved and upgraded and require this level of Linux software.

 

I installed ISE 14.7

I cannot complete installation of the drivers part because of incompatibility.

At this stage I need basic help:

 

I am willing paying for the Jungo driver, just to be able to work!

I downloaded and trivially installed their ONE MONTH FREE TRIAL.

Reinstalling the ISE 14.7 drivers, the failure to compile  windrvr disappeared because windrvr6.ko and windrvr-usb.ko were of course readily available.

The installation failed on trying to compile xpc4drvr.

 

1-Is it correct that since my JTAG cable is USB I just don't need xpc4drvr as long as I accept to have to set up the cable "manually"?

2-If correct, how can I bypass without damage the comilation and installation of xpc4drvr?

3-I of course started and retried WITHOUT using the JUNGO windrvr6, then both sections failed, windrvr and xpc4drvr.

4-There are indeed several "guides" on the Web claiming to solve the problem, all what I found failed the same way at the same place albeit with not always the same error messages.

 

Thanks in advance for any help. I will send a relevant log upon request.

 

Jacques

0 Kudos