UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
10,011 Views
Registered: ‎10-11-2017

No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

I have a custom board.I am using Vivado2017.2 on Windows 7. After generating a bitstream, I go to Hardware Manager => Open Target => Autoconnect and immediately get the error:

 

ERROR: [Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Check cable connectivity and that the target board is powered up then

use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

ERROR: [Common 17-39] 'open_hw_target' failed due to earlier errors

 

I have also tried to run the command:

<Installed_area_vivado>\2017.2\bin\vcse_server.bat -port 60001

But it shows:

 1.png

Thanks for any help.

0 Kudos
1 Solution

Accepted Solutions
Adventurer
Adventurer
10,572 Views
Registered: ‎10-11-2017

回复: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution
I changed the cable and it works fine now.
14 Replies
Xilinx Employee
Xilinx Employee
10,002 Views
Registered: ‎08-01-2008

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution
check these links
https://www.xilinx.com/support/answers/54012.html
https://forums.xilinx.com/t5/Configuration/XC7A35T-not-recognised-on-JTAG/td-p/596288
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Moderator
Moderator
9,980 Views
Registered: ‎01-15-2008

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution
  1. Have you tried with different programming cable to see if the issue does not apply to cable?
  2. Have you tried with other USB ports ? Sometimes there is power problem with USB ports.
0 Kudos
Adventurer
Adventurer
9,977 Views
Registered: ‎10-11-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Thanks!

But I don't use ZC702 Evaluation Kit Board,I design my board with Kintex-7 FPGA  xc7k325tffg900-2,

when I Open Target => Autoconnect  ,it shows   No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

2.png

I have read this link:https://www.xilinx.com/support/answers/61312.html

Does it mean that only  the xilinx official Evaluation Kit Board can be detected while user's custom board can not be detected automaticlly?

0 Kudos
Moderator
Moderator
9,962 Views
Registered: ‎02-09-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Hi @kristen123

 

If the chip is Xilinx, it should work ok (no matter if it's an official Evaluation Kit Board or user's custom board).

 

In the path localhost:3121/xilinx_tcf/Xilinx/00000000000000 those bunch of zeroes should actually be the device ID. In your case, the zeroes show that there is really something wrong with detecting the device.

 

Can you try to instead of hitting the autoconnect button, hit Open Target -> Open New Target.

 

It will open the Connect Hardware Wizard and when you click next, if devices have been detected, you should see something like this:

 

open hardware wizard.JPG

 

Please make sure the device is powered on. Also, what kind of cable are you using? Maybe try using another cable (just about any regular micro USB cable) just to make sure the cable is not the source of the problem.

 

Thanks.

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
9,951 Views
Registered: ‎10-11-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Thanks!

When I hit Open Target--Open New Target,It shows:

3.png

The device is powered on.I have changed the cable but it still doesn't work. 

0 Kudos
Adventurer
Adventurer
9,944 Views
Registered: ‎10-11-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

I found that my device can be detected correctly in ISE14.7,So  I think my custom board is ok.There must be something wrong in Vivado

0 Kudos
Adventurer
Adventurer
9,932 Views
Registered: ‎10-11-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Thanks!

I found that the device can be detected in ISE14.7,but can not be detected in Vivado,there must be something wrong with vivado.The cable and USB port is ok.

0 Kudos
Moderator
Moderator
9,922 Views
Registered: ‎10-19-2011

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Are you using the latest Vivado Drivers?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
9,883 Views
Registered: ‎10-11-2017

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Hi@travisc

Where can I find the latest Vivado DriverI install the driver from the  software installation directory C:\Xilinx...

0 Kudos
Adventurer
Adventurer
10,573 Views
Registered: ‎10-11-2017

回复: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution
I changed the cable and it works fine now.
Newbie skitnado25
Newbie
7,125 Views
Registered: ‎04-13-2018

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

So I had the same problem but what I noticed was that it had nothing to do with the cable but when I unplugged USB cable from my USB hub and plugged it directly to PC it delivered the right current to power my board.

0 Kudos
Visitor ashok_b
Visitor
7,084 Views
Registered: ‎04-16-2018

No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

Hello,

I'm trying to connect JTAG  to the Zynq XC7Z045 via Digilent JTAG SMT2 module, but error occured as shown in jpeg file below.

Also how different is our custom design from ZC706 EVK is that we have removed the JTAG chain and using only Digilent module to access the port. But getting the error as shown below.

Please help me to resolve this ASAP.

JTAG_Error.jpg

 

Regards,

Ashok Chandra

0 Kudos
Newbie nocroom
Newbie
6,289 Views
Registered: ‎08-10-2018

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

im having this same issue, what is the fix to this ?

0 Kudos
Visitor feng11111111
Visitor
3,252 Views
Registered: ‎02-17-2019

Re: No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00000000000000.

Jump to solution

请问你这个问题解决了吗?是如何解决的。

0 Kudos