UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor szanto
Visitor
2,579 Views
Registered: ‎12-07-2017

Platform cable USB II and Windws 10 fall creators update

Hi,

 

Since Windows 10 was updated to the fall creators update, the Platform USB cable stopped working. In device manager it is listed as "Xilinx Platform Cable USB Firmware Loader", so it seems to me that the USB device is recognized correctly, but the driver does not load the firmware to the cable's chip.

I can reproduce the problem on multiple computers, while the cable works correctly on Windows 7. Development boards with Digilent cable works.

 

Is there any solution?

 

Regards,

 

Peter

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
2,572 Views
Registered: ‎08-01-2008

Re: Platform cable USB II and Windws 10 fall creators update

you can follow these steps in here:

 http://www.eevblog.com/forum/microcontrollers/guide-getting-xilinx-ise-to-work-with-windows-8-64-bit/

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Visitor szanto
Visitor
2,547 Views
Registered: ‎12-07-2017

Re: Platform cable USB II and Windws 10 fall creators update

Hi,

 

This is not an ISE related problem, I use Vivado. But anyhow, it is not related to the design SW, it seems to be a driver issue, if I plug in the cable, the LED is not turned on.

As I wrote, the platform cable did work before Fall creators update, but it fails to do so since then. Digilent driver works ok.

 

Regards,

 

Peter

0 Kudos
Moderator
Moderator
2,533 Views
Registered: ‎04-12-2017

Re: Platform cable USB II and Windws 10 fall creators update

Hello @szanto,

 

Please try updating the Jungo Drivers of your system:

https://www.jungo.com/st/products/windriver/

 

Also follow below steps:

1) Delete windrvr6.sys from C:\Windows\drivers

 

2) Run install_drivers.exe from <Path to ISE folder>\bin\nt64

 

3) Reboot computer

 

Please disable the antivirus and firewall once and check if it works after that.

 

Also what is the status of the LED on platform cable ? 

Please try reinstalling the drivers as well.

https://www.xilinx.com/support/answers/59128.html

 

Let us know if all this above checks help setup the cable with windows 10.

 

Thank you.

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor szanto
Visitor
2,449 Views
Registered: ‎12-07-2017

Re: Platform cable USB II and Windws 10 fall creators update

Hi kvasantr,

 

As I wrote I do not use ISE, I use Vivado. And I did not find any end-user driver at Jungo.

 

Anyway I tried to remove all Xilinx related drivers, so the cable was identified as an Unknown device. Then I installed the driver through device manager, but I afterwards I still see it as the following:

xil_usb_devman.jpg 

The driver details:

xil_usb_devman.jpg

 

And the status LED is not turned on.

 

During normal operation the cable is identified as a "Xilinx USB Cable" in device manager, this is why I think that there may be a problem loading the cable's firmware into the cable itself.

 

Peter

0 Kudos
Highlighted
Newbie victor36
Newbie
782 Views
Registered: ‎05-05-2019

Re: Platform cable USB II and Windws 10 fall creators update

Hi Peter,

Did you solved the driver problem eventually ?

I'm having the same issue on new Windows 10 version, stuck at Xilinx Platform Cable USB Firmware Loader.

Normally  the "Xilinx Platform Cable USB Firmware Loader"(VID_03FD&PID_000F) load the Cypress CY7C68013 chip on the cable with a xilinx firmware and renumerate as "Xilinx USB Cable"(VID_03FD&PID_0008), which is not the case on Windows 10.

Installed Vivado 2018.3 Lab, googled a lot, still no clue why it doesn't load or renumerate on WIN10.

Victor

0 Kudos
Newbie kschoemehl
Newbie
463 Views
Registered: ‎09-03-2019

Re: Platform cable USB II and Windws 10 fall creators update

I've been trying to resolve this same problem for a few hours and here is what finally worked for me.  I'm not sure how much of the below was necessary:

open a command prompt with administrative priviledges

Navigate to [install directory]\Xilinx\Vivavo\20xx.x\data\xicom\cable_drivers\nt64\dlc10_win7

run check_windrvr6.exe

run install_drivers.exe

at this point in time, I noticed that the Jungo Windriver now appeared in Device Manager (previously it was not there)

Uninstall the drivers for the Xilinx Platform Cable II Firmware Loader, make sure to check the box to delete the files as well

Reconnect the Platform Cable USB II, after a few seconds the light came on and all of the correct drivers identified

 

Hope this helps

Kevin

0 Kudos