Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎10-12-2016

SDK & Zedboard: Port COM4 is already in use.



I'm Running Vivado 16.2 with SDK 16.2 on Windows 10, with Zedboard rev C.


I have previously been able to work on my old Windows 7 computer. I have now exported the Zedboard project to a new computer with Windows 10. On the new computer, I can program the FPGA from SDK. But when I try to run the software with Run As->Launch on Hardware (GDB), the SW project builds and stops with the error message

Port COM4 is already in use.


I have checked that no other program uses the COM port. It seems like Eclipse itself opens the COM4 port, and then tries to do it again, or something.


Process Explorer search for "serial" shows:

Process  |  Name

rdi_xmd.exe | C:\Xilinx\SDK\2016.2\lib\...\libboost_serialization.dll

eclipse.exe | C:\Xilinx\SDK\2016.2\eclipse\...\rxtxSerial.dll,

vivado.exe | C:\Xilinx\SDK\2016.2\lib\...\libboost_serialization.dll



I guess this means that if there is a program holding the serial port, it's Eclipse itself.

Quitting Vivado doesn't help.


Restarting the computer and Zedboard didn't help

I have tried to disable the port in Device Manager, and enable it again. That didn't help.

I have uninstalled the port driver, and let it automatically be reinstalled when I plugged the USB cable in. Didn't help.


I didn't have these problems on the old computer.

Do anyone have any clue?


Thanks in advance,



Tags (4)
0 Kudos
3 Replies
Registered: ‎10-12-2016

It seems like the SDK Terminal tab has taken COM4, so the Console tab cannot take it, or something.

Could this be the case? If so, how do I solve it?


Could the following be related:

(This is an old Eclipse serial port bug, which should be solved by now, but perhaps something similar has popped up again.).


I have tried to lock COM4 by opening it in TeraTerm before starting SDK. But then it is not possible to configure the Zynq PL from Xilinx SDK. So it seems like the COM4 port is used when configuring the Zynq PL for some reason. I thought JTAG would be enough. But then "something" forgets to close COM4, preventing the Console to open COM4.


Do someone have a cluie?

0 Kudos
Registered: ‎10-12-2016

Now I have done some more investigations, to find out exactly when COM4 becomes busy. It is when I program the FPGA.

(When I have clicked the SDK Toolbar button Program FPGA, and then clicked the Program button in the Program FPGA dialog box.) Then COM4 stays busy. That's why the console can not access COM4.


I thought programming the FPGA was done via JTAG and not via a COM port. Why does programming the FPGA occupy a COM port?


0 Kudos
Registered: ‎06-26-2014

I used to have the same problem, but this can be easily solved when you choosed the correct COM. You'd better check the device manager on your PC. All the ports are listed there. The COM used in SDK should be the same with the choice in the device manager.

The JTAG also occupies a COM on your PC. So if it shows "Port COM4 is already in use", that is because COM4 on your PC is assigned to JTAG. You can use another port.

This method can solve my problem every time with this error occurs. Hope it will help you too.

I am a freshmen of FPGA. But I know everything is ok if I work hard.
0 Kudos