UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer rleopold
Observer
14,744 Views
Registered: ‎04-30-2014

Vivado 2014.1, Debug

I'm using Vivado 2014.1.  I've been having several issues using an "ila" embedded in the design.  I seem to be having issues with "vcse_server".  I am compiling for the KC705 board.  My error today is the following:

 

INFO: [Labtools 27-1964] The ILA core 'hw_ila_1' trigger was armed at 2014-May-13 13:43:12
wait_on_hw_ila hw_ila_1
display_hw_ila_data [upload_hw_ila_data hw_ila_1]
INFO: [Labtools 27-1966] The ILA core 'hw_ila_1' triggered at 2014-May-13 13:43:12
ERROR: [Labtools 27-147] vcse_server: Arg. to function CseILA_unrollTraceMemory() failed:traceMemorySize >= (samplewordsizewithmark * sampleCnt * windowCnt)
ERROR: [Labtools 27-147] vcse_server: Could not get Parameter: trace_data.
ERROR: [Labtools 27-1829] vcse_server failed during internal command 'CseXsdb_getParameters'. See previous error messages.

 

I cycled power on the board.  Disconnected the JAG cable.  Closed out the design.  And finally closed Vivado completely.  I still get the same message.

 

Any thoughts?

0 Kudos
12 Replies
Xilinx Employee
Xilinx Employee
14,743 Views
Registered: ‎02-16-2014

Re: Vivado 2014.1, Debug

Hi,

 

Is the design is build in 2014.1 or any other version?

 

Can you try setting the trigger within the range?

 

0 Kudos
Observer rleopold
Observer
14,731 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

It's a new design started in 2014.1.

0 Kudos
Observer rleopold
Observer
14,722 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

Yes I made sure the trigger point was valid.  I'm creating a new ila and re compiling the design.

0 Kudos
Xilinx Employee
Xilinx Employee
14,717 Views
Registered: ‎02-16-2014

Re: Vivado 2014.1, Debug


Can you check whether there are any timing violations in the design?
This may happen if the ILA did not meet the timing.
0 Kudos
Observer rleopold
Observer
14,712 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

After I created a new ila and recompled it works so I can't check the timing.

0 Kudos
Observer rleopold
Observer
14,707 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

After I recompiled and added more test points i get this message:

 

ERROR: [Labtools 27-147] vcse_server: Invalid Register Name: MU1033_WIDTH
ERROR: [Labtools 27-1829] vcse_server failed during internal command 'CseXsdb_getRegisters'. See previous error messages.

0 Kudos
Moderator
Moderator
14,683 Views
Registered: ‎01-16-2013

Re: Vivado 2014.1, Debug

Hello,

1) As Manusha asked you did you checked the timing of ILA?
Is it meeting the requirements?

2) Is your Vivado (design build) version and HW manager version is same?

Thanks,
Yash
0 Kudos
Observer rleopold
Observer
14,659 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

All of the tools were installed at the same time so I think everything is 2014.1.  I do not see any timing errors associated with the ila.  When I go to Help/About Vivado I get this:

 

        Vivado v2014.1 (64-bit)
SW Build 881834 on Fri Apr 4 14:15:54 MDT 2014
IP Build 877625 on Fri Mar 28 16:29:15 MDT 2014

 

Windows 7, 64 bit

0 Kudos
Observer rleopold
Observer
14,159 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

ERROR: [Labtools 27-147] vcse_server: Arg. to function CseILA_unrollTraceMemory() failed:traceMemorySize >= (samplewordsizewithmark * sampleCnt * windowCnt)

 

Getting the same error in 2014.2 now.

0 Kudos
Observer rleopold
Observer
9,799 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

Oh and I have no timing errors.
0 Kudos
Observer rleopold
Observer
9,797 Views
Registered: ‎04-30-2014

Re: Vivado 2014.1, Debug

ERROR: [Labtools 27-147] vcse_server: Arg. to function CseILA_unrollTraceMemory() failed:traceMemorySize >= (samplewordsizewithmark * sampleCnt * windowCnt)
ERROR: [Labtools 27-147] vcse_server: Could not get Parameter: trace_data.
ERROR: [Labtools 27-1829] vcse_server failed during internal command 'CseXsdb_getParameters'. See previous error messages.
0 Kudos
Visitor maxinquaye
Visitor
9,695 Views
Registered: ‎07-28-2014

Re: Vivado 2014.1, Debug

Got that error also a lot. It works better since I decreased JTAG frequency to the minimum (750000 Hz).

0 Kudos