cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
11,215 Views
Registered: ‎07-28-2014

Vivado 2014.2 crashes when opening target in hardware manager

This happened a few times now. Here is the latest error message:

 

#
# An unexpected error has occurred (11)
#
Stack:
/Xilinx/Vivado/2014.2/tps/lnx64/jre/lib/amd64/server/libjvm.so(+0x8127a9) [0x7fbe6e0e47a9]
/Xilinx/Vivado/2014.2/tps/lnx64/jre/lib/amd64/server/libjvm.so(JVM_handle_linux_signal+0xb6) [0x7fbe6e0ea216]
/lib64/libc.so.6(+0x385b0) [0x7fbe9516e5b0]
/Xilinx/Vivado/2014.2/lib/lnx64.o/librdi_xicom_hw.so(XicomHWXicomGetDevicePropertiesCmd::getCfgmemSupported()+0) [0x7fbe73170680]
/Xilinx/Vivado/2014.2/lib/lnx64.o/librdi_labtools.so(Java_ui_data_labtools_lthwdatai_HWDevice_1isXicomCfgMemSupported+0x17) [0x7fbe772163e7]
[0x7fbe67d5f2d1]

0 Kudos
5 Replies
Highlighted
Xilinx Employee
Xilinx Employee
11,213 Views
Registered: ‎04-16-2012

Hi,

Is this issue intermittent?
Provide the steps that helps to reproduce the issue.


Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Visitor
Visitor
11,210 Views
Registered: ‎07-28-2014

Hi, yes it only happens occasionally but I haven't made out any pattern. Maybe important: I use a remote server. Version 2014.2 of hw_server is installed.

 

It just crashed again when I tried to modify the JTAG frequency giving out this slightly different error message:

 

#
# An unexpected error has occurred (11)
#
Stack:
/Xilinx/Vivado/2014.2/tps/lnx64/jre/lib/amd64/server/libjvm.so(+0x8127a9) [0x7f2b442f57a9]
/Xilinx/Vivado/2014.2/tps/lnx64/jre/lib/amd64/server/libjvm.so(JVM_handle_linux_signal+0xb6) [0x7f2b442fb216]
/lib64/libc.so.6(+0x385b0) [0x7f2b6b37f5b0]
/Xilinx/Vivado/2014.2/lib/lnx64.o/librdi_xicom_hw.so(XHWDevice::getCfgmemSupported()+0) [0x7f2b49344ea0]
/Xilinx/Vivado/2014.2/lib/lnx64.o/librdi_labtools.so(Java_ui_data_labtools_lthwdatai_HWDevice_1isXicomCfgMemSupported+0x17) [0x7f2b4d4273e7]
[0x7f2b3d297e4d]

Earlier crashes happened when I tried to open a recent target directly or when I tried to connect to the remote server.

 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
11,185 Views
Registered: ‎07-31-2012

Hi,

 

What is your server operating system and the client operating system?

 

End the hw_server processes on your client machine (you sometimes have to end it from the task manager) and try creating a new one. See if it works now.

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos
Highlighted
Visitor
Visitor
11,162 Views
Registered: ‎07-28-2014

Hi, I restarted hw_server but the problem stayed the same.

 

Operating systems:

Server: Gentoo

Client: Scientific Linux CERN SLC release 5.10 (Boron)

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
11,101 Views
Registered: ‎07-31-2012

Hi,

 

If possible diable firewall and check if it works.

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos