UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer dreamertom
Observer
3,572 Views
Registered: ‎06-16-2017

Waveform Data Read From ILA Core Is Corrupted

Hi,

I'm using VIVADO 2016.1 and I try to use VIO and ILA in a same design. At the beginning, I can read back data and display waveform from the ILA core. After I adding 4 new probes of signals into the ILA, then I can trigger it but it corrupted when it uploading data and no waveform been displayed. I can get the error message shown in the image below.

pic1

The clock connected to the ILA is a 200Mhz free running clock from a crystal, and the JTAG clock is a 6Mhz clock. I also tried a 3Mhz JTAG clock and it didn't work either. After that, I will try to reduce the number of signals connected to the ILA later. I wonder know the number limits that I can connect to the ILA core by the setup debug tool in VIVADO.

Thanks.

0 Kudos
4 Replies
Moderator
Moderator
3,568 Views
Registered: ‎07-01-2015

Re: Waveform Data Read From ILA Core Is Corrupted

Hi @dreamertom,

 

Is timing met for the design?

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Observer dreamertom
Observer
3,558 Views
Registered: ‎06-16-2017

Re: Waveform Data Read From ILA Core Is Corrupted

I find that I forget adding the clock timing constraints. I will try again after adding it.

0 Kudos
Moderator
Moderator
3,512 Views
Registered: ‎09-15-2016

Re: Waveform Data Read From ILA Core Is Corrupted

Hi @dreamertom,


Please ensure all timing constraints are met before debugging and you have properly constrained all the paths.

 

Please check the below Answer record:

 

https://www.xilinx.com/support/answers/62421.html 

 

Regards,

Sravanthi B

 

Thanks & Regards,
Sravanthi B
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Moderator
Moderator
3,492 Views
Registered: ‎07-01-2015

Re: Waveform Data Read From ILA Core Is Corrupted

Hi @dreamertom,

 

Are you able to debug after taking care of timing constraints?

Thanks,
Arpan
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos