UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar helmutforren
Scholar
8,954 Views
Registered: ‎06-23-2014

XPS Microblaze Interrupt Setting MISSING?

In XPS 14.7, I'm trying to recreate from scratch a reference design originated in XPS 12.4.  I've got almost everything worked out, except for an issue with the microblaze interrupt.  Please see the two images below.  Do I need to resolve this?  And if so, how do I do it, please?  (I've edited the images for brevity, then highlighted in yellow my points of question)

 

From the original XPS 12.4 design:

Microblaze Interrupt Forum Post (XPS 12.4).jpg

 

 

From my recreated XPS 14.7 design:

Microblaze Interrupt Forum Post (XPS 14.7).jpg

 

 

 

0 Kudos
2 Replies
Scholar sampatd
Scholar
8,923 Views
Registered: ‎09-05-2011

Re: XPS Microblaze Interrupt Setting MISSING?

In XPS 14.7, you will find the INTERRUPT in the bus interfaces tab:

 

mb_intr.png

0 Kudos
Scholar helmutforren
Scholar
8,917 Views
Registered: ‎06-23-2014

Re: XPS Microblaze Interrupt Setting MISSING?

Doh!  They MOVED it!  Thanks.  But NOW WHAT?  

 

It says "No Connection" and doesn't provide any alternative in the dropdown box.

 

Meanwhile, I went to the xps_intc_0, which still has interrupt on the Ports tab.  The only internal choice it would allow me is "xps_intc_0::Intr".  So I chose that.  But back on the Bus Interfaces tab for microblaze_0, it will won't let me select anything other than "No Connection".

 

Thanks for the changed tab advice, and thanks in advance if you can get me past the above.

0 Kudos