cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
arasch
Observer
Observer
1,796 Views
Registered: ‎03-14-2018

ZC706 "Program Device" grayed out

Jump to solution

Hi

I have a ZC706 Evaluation Board and am running Vivado 2018.2. I would like to program the Zynq using just USB cable. Unfortunately the computer I am using has only 2 USB hubs, so I am using a 4-Port USB 2.0 Hub to be able to connect the 2 cables from the ZC706 board besides the connections required for keyboard and mouse.

I have the SW4 set to 01 and SW11 to 00000.

When I try to Auto connect in Vivado to the hardware "Program Device" stays grayed out. Also trying to Program FPGA from the Xilinx SDK results in an error message that the communication to the hardware is not working.

Thanks for any hint on what I am doing wrong.

 

zc706.jpg
0 Kudos
1 Solution

Accepted Solutions
hj
Moderator
Moderator
1,892 Views
Registered: ‎06-05-2013
• CentOS 7.2, 7.3, and 7.4 (64-bit)
• CentOS 6.7, 6.8, and 6.9 (64-bit)
These are supported with Vivado 2018.2. If you are using any of those then it should work.

Next re-install the cable drivers. https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_2/ug973-vivado-release-notes-install-license.pdf
Page#30

Thanks
harshit
-------------------------------------------------------------------------------------
For more information please refer to configuration resources https://forums.xilinx.com/t5/FPGA-Configuration/Configuration-Resources/m-p/753763/highlight/true#M5891
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
6 Replies
hj
Moderator
Moderator
1,780 Views
Registered: ‎06-05-2013

@arasch

 

Can you share the snapshot from Vivado HW manager? Make sure no other HW server session is open. 

Also try to reconnect the board. Use the red circled switch as well. 

Capture.JPG

 

Try to use the TCL command if any useful error message is triggered:

 

set_property PROGRAM.FILE {C:/impl_1/Golden.bit} [get_hw_devices xc7z045_1]
program_hw_devices [get_hw_devices xc7z045_1]

 

Thanks

Harshit

-------------------------------------------------------------------------------------
For more information please refer to configuration resources https://forums.xilinx.com/t5/FPGA-Configuration/Configuration-Resources/m-p/753763/highlight/true#M5891
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
arasch
Observer
Observer
1,770 Views
Registered: ‎03-14-2018

Hi @hj

Thanks for the quick reply.

Please see the screenshot attached. I don't seem to get further than the localhost. Also tried the refresh_hw_server option.

 

I should also add that I am using CentOS Linux.

Best Regards 

Screenshot from 2018-08-06 07-15-00.png
0 Kudos
hj
Moderator
Moderator
1,766 Views
Registered: ‎06-05-2013

Try to check task manager is there any hardware session(hw_server.exe) /SDK open. End the process for all of them and try to re-connect the board. 

Use only one session at a time. I can see SDK open in your snapshot.

 

Capture_1.JPG

 

Restart vivado or close the local server and re-connect the HW. 

 

Capture.JPG


ZC706 mode pins for JTAG should be SW4 --> 01 

 

Thanks

harshit

-------------------------------------------------------------------------------------
For more information please refer to configuration resources https://forums.xilinx.com/t5/FPGA-Configuration/Configuration-Resources/m-p/753763/highlight/true#M5891
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
arasch
Observer
Observer
1,758 Views
Registered: ‎03-14-2018

Hi @hj

Thanks for the reply.

I am running Vivado on CentOS-7 Linux and (after running "source /opt/Xilinx/Vivado/2018.2/settings64.sh") I am starting it just with

> vivado &

Is there anything else I have to do on Linux?

Could the USB hub be an issue?

Best

0 Kudos
hj
Moderator
Moderator
1,893 Views
Registered: ‎06-05-2013
• CentOS 7.2, 7.3, and 7.4 (64-bit)
• CentOS 6.7, 6.8, and 6.9 (64-bit)
These are supported with Vivado 2018.2. If you are using any of those then it should work.

Next re-install the cable drivers. https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_2/ug973-vivado-release-notes-install-license.pdf
Page#30

Thanks
harshit
-------------------------------------------------------------------------------------
For more information please refer to configuration resources https://forums.xilinx.com/t5/FPGA-Configuration/Configuration-Resources/m-p/753763/highlight/true#M5891
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
arasch
Observer
Observer
1,745 Views
Registered: ‎03-14-2018

Thanks so much -- of course forgot to install the driver on Linux...

Now it works.