cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Tetra57
Visitor
Visitor
543 Views
Registered: ‎05-19-2021

disable the suggestion on vivado

Jump to solution

Hello.

I've recently started to use Vivado and felt inconvenience about the text editor.

How can I disable the suggestion?

0 Kudos
1 Solution

Accepted Solutions
barriet
Xilinx Employee
Xilinx Employee
480 Views
Registered: ‎08-13-2007

Try:

menu: Tools -> Settings, Text Editor, Code Completion -> Disable Code Completion.

There's quite a few other settings you can check out. Or certainly welcome to use a different text editor.

View solution in original post

6 Replies
joancab
Advisor
Advisor
534 Views
Registered: ‎05-11-2015

what inconvenience? which suggestion?

0 Kudos
dpaul24
Scholar
Scholar
528 Views
Registered: ‎08-07-2014

@Tetra57 

How can I disable the suggestion?

Which suggestion?

If u want to use the text editor of your choice: Tools -- Settings -- TextEditor -- Change to the text editor of your choice!

------------FPGA enthusiast------------
Consider giving "Kudos" if you like my answer. Please mark my post "Accept as solution" if my answer has solved your problem

Tetra57
Visitor
Visitor
494 Views
Registered: ‎05-19-2021

@dpaul24 @joancab 

I thought I attached a picture, but it didn't work. Sorry about that.

As you can see in the image, it is the function that are analogous to the characters I type.

 

2021-05-19.png

barriet
Xilinx Employee
Xilinx Employee
481 Views
Registered: ‎08-13-2007

Try:

menu: Tools -> Settings, Text Editor, Code Completion -> Disable Code Completion.

There's quite a few other settings you can check out. Or certainly welcome to use a different text editor.

View solution in original post

joancab
Advisor
Advisor
461 Views
Registered: ‎05-11-2015

Oh, man, that I also wanted to disable, it's simply anti-helpful (meaning worse than not helpful, or negative helpfulness, mathematically speaking)

joancab_0-1621449521447.png

 

0 Kudos
Tetra57
Visitor
Visitor
405 Views
Registered: ‎05-19-2021

@barriet Thank you, it works.

@joancab Definitely. I disabled it and it got so much clear and nicer.

0 Kudos