UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
5,025 Views
Registered: ‎05-02-2017

iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

 

Welcome to iMPACT
iMPACT Version: 14.7
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
GUI --- Auto connect to cable...
// *** BATCH CMD : setCable -port auto
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
If you are using the Platform Cable USB, please refer to the USB Cable Installation Guide (UG344) to install the libusb package.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Linux release = 4.13.0-32-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.

Connecting to cable (Parallel Port - parport0).
 Linux release = 4.13.0-32-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.
Connecting to cable (Parallel Port - parport1).
 Linux release = 4.13.0-32-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.
Connecting to cable (Parallel Port - parport2).
 Linux release = 4.13.0-32-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.
Connecting to cable (Parallel Port - parport3).
 Linux release = 4.13.0-32-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =     59 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

 

 

I am facing the above error when using ISE IMPACT with ML605.

 

I have tried solution such as https://www.xilinx.com/support/documentation/user_guides/ug344.pdf#page=17 but it resulted in https://www.questarter.com/q/install-xilinx-platform-usb-in-ubuntu-16-04-x64-3_838260.html which is not suitable in newer linux kernel version.

I have also tried https://askubuntu.com/a/927901 but the ./install_drivers script within vivado SDK does not help solve this error either.

 

Besides, compiling http://dreamrunner.org/blog/2012/09/12/install-xilinx-ise-on-the-ubuntu/ gave me some errors. I suppose this solution does not support ISE 14.7 yet.

 

Could anyone advise ?

Tags (2)
0 Kudos
6 Replies
Moderator
Moderator
4,968 Views
Registered: ‎02-09-2017

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Hi @user123random,

 

What distro and version of Linux are you using? ISE is a significantly old software and unfortunately it might be difficult to get drivers to work on a new OS's.

 

Also, what kind of cable are you using (Digilent or Xilinx USB cable)?

 

You might have to install the drivers from the Vivado installation. Please take a look at the following AR, which points a workaround to install the drivers for each cable on newer OS's: https://www.xilinx.com/support/answers/64361.html

 

 

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
4,954 Views
Registered: ‎05-02-2017

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Hi @anunesgu

 

I am using Linux UbuntuHW15 4.13.0-32-generic #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

 

I am still stucked at cable driver installation error even after trying your previous solution.  By the way, I could get UART on ML605 working now.  Is it possible to download bitstream to ML605 using UART ?

 

********************************************************
********************************************************
**     Xilinx Virtex-6 FPGA ML605 Evaluation Kit      **
********************************************************
********************************************************
Choose Feature to Test:
1: UART Test
2: LED Test
3: Timer Test
4: FLASH Test
5: IIC Test
6: Ethernet Loopback Test
7: Switch Test
8: External Memory Test
9: System Monitor Test
A: PushButton Test
B: LCD Test
C: System ACE CF Test
D: DVI/VGA Test
1
Reading SRECORDS from Linear BPI Flash at: 0x7C920000
Bootloader: Processed (0x)0000012c S-records
Executing program starting at address: 00000000

********************************************************
********************************************************
**     ML605 - UART Test                              **
********************************************************
********************************************************
Testing UART
9600,8,N,1
Hello world!
UART Test Passed


********************************************************
********************************************************
**     Xilinx Virtex-6 FPGA ML605 Evaluation Kit      **
********************************************************
********************************************************
Choose Feature to Test:
1: UART Test
2: LED Test
3: Timer Test
4: FLASH Test
5: IIC Test
6: Ethernet Loopback Test
7: Switch Test
8: External Memory Test
9: System Monitor Test
A: PushButton Test
B: LCD Test
C: System ACE CF Test
D: DVI/VGA Test
0 Kudos
Adventurer
Adventurer
4,942 Views
Registered: ‎05-02-2017

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Even when I try in Windows 10, I have the same problem as illustrated below. Could anyone advise ?

 

Screenshot (2).png

0 Kudos
Moderator
Moderator
4,926 Views
Registered: ‎02-09-2017

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Hi @user123random,

 

Unfortunately you cannot use the UART to program the board. Also, unfortunately Windows 10 is not an officialy supported OS for ISE.


Are you looking only to program the board? Or are you using the ISE to do the design as well?

 

If the issue is programming it, I recommend you install the Vivado Lab Edition, which is free and will come with the latest cable drivers.

 

In fact, after you install that, it might actually get the drivers for ISE to work as well. Could you please try that?

 

You can get the Vivado Lab Edition from the following link:

 

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-tools/2017-4.html

 

Please let us know how that goes.

 

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Newbie ollewelin
Newbie
4,325 Views
Registered: ‎05-08-2018

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Also get the

WARNING:iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.

when I start iMPACT from

/opt/Xilinx/14.2/ISE_DS/ISE/bin/lin64$ sudo ./impact

 

I was install both Vivado and ISE14.2 on Linux Ubuntu 16.04. I was install cable driver

/opt/Xilinx/Vivado_Lab/2018.1/data/xicom/cable_drivers/lin64/install_script/install_drivers/

$ sudo bash install_drivers

and get answer after install..

...

INFO: Driver installation successful.
CRITICAL WARNING: Cable(s) on the system must be unplugged then plugged back in order for the driver scripts to update the cables.

 

Should I try start iMPACT from Vivado Lab tool instead? I will try..

The LED on Platform Cable USB II is Green and attached to a proper Spartan6 target

Best regards

Olle Welin

0 Kudos
Newbie ollewelin
Newbie
4,323 Views
Registered: ‎05-08-2018

Re: iMPACT - Module windrvr6 is not loaded. Please reinstall the cable drivers

Got this Error also when I start iMPACT on Ubuntu 16.04

I was install cable driver like this

 

/opt/Xilinx/Vivado_Lab/2018.1/data/xicom/cable_drivers/lin64/install_script/install_drivers$ sudo bash install_drivers
INFO: Installing cable drivers.
INFO: Script name = install_drivers
INFO: HostName = dator12345-Lenovo-Y50-70
INFO: Current working dir = /opt/Xilinx/Vivado_Lab/2018.1/data/xicom/cable_drivers/lin64/install_script/install_drivers
INFO: Kernel version = 4.13.0-39-generic.
INFO: Arch = x86_64.
USB udev file exists and will not be updated.
--File /etc/udev/rules.d/52-xilinx-ftdi-usb.rules exists.
--File /etc/udev/rules.d/52-xilinx-ftdi-usb.rules version =
--File 52-xilinx-ftdi-usb.rules exists.
--File 52-xilinx-ftdi-usb.rules version =
--File 52-xilinx-ftdi-usb.rules is newer than the destination file.
--Updating rules file.
--File /etc/udev/rules.d/52-xilinx-pcusb.rules exists.
--File /etc/udev/rules.d/52-xilinx-pcusb.rules version = 0002
--File 52-xilinx-pcusb.rules exists.
--File 52-xilinx-pcusb.rules version = 0002
--File 52-xilinx-pcusb.rules is already updated.

INFO: Digilent Return code = 0
INFO: Xilinx Return code = 0
INFO: Xilinx FTDI Return code = 0
INFO: Return code = 0
INFO: Driver installation successful.
CRITICAL WARNING: Cable(s) on the system must be unplugged then plugged back in order for the driver scripts to update the cables.

 

One time I got the LED on programmer Green but the Error occur anyway when start iMPACT

Now the LED is OFF always.

 

I use USB cable

I go the Info:

 

If you are using the Platform Cable USB, please refer to the USB Cable Installation Guide (UG344) to install the libusb package.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Linux release = 4.13.0-39-generic.

WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.
INFO:Cse - The fxload application is not installed. This application is required when using the Platform Cable USB. This warning should be ignored if you are using the Parallel Cable III or Parallel Cable IV. Please download and install the fxload-2002_04_11 package. Note that root access is required to perform the installation.
Connecting to cable (Parallel Port - parport0).
 Linux release = 4.13.0-39-generic.

 

Question ?

Dose the old

fxload-2002_04_11 package

really working on Ubuntu 16.04 ???

Best Regards

Olle Welin

 

0 Kudos