UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie kwturner
Newbie
8,111 Views
Registered: ‎07-17-2013

iMPACT - SPI Flash Bootloading issue

Hi,

 

I am having issues programming a bootloader into my 128M external SPI flash memory, connected to a Spartan 6 (on a custom PCB).

 

The FPGA design and all firmware have been completed using Altium.  Currently, I can load the FPGA using the iMPACT tool, but to successfully load the bootloader, I have to then open Altium, go to devices, and manually download softcore .hex file.  The FPGA is connected on a JTAG line and I am using the Platform Cable USBII to connect with iMPACT.

 

I have tried adding SPI Flash via iMPACT and loading my .mcs file in that way - when I right click -> program the SPI device, iMPACT will indicate a success, yet my code clearly never runs and upon a power cycle, I can see that the bootloader is not working.

 

I have also tried using the PROM generator, to generate a new .mcs file using my Altium generated .bit and .hex files.  Programming this into flash also indicates a success, but the program does not load (same as above).

 

Another thing to note is that I am using a Macronix Flash device, which is not officailly supported by iMPACT - I have been following another post which indicated success by skipping the ID check and using the N25Q128 part in iMPACT.

 

Any ideas or suggestions would be appreciated.

 

Thanks

 

0 Kudos
1 Reply
Community Manager
Community Manager
8,076 Views
Registered: ‎07-23-2012

Re: iMPACT - SPI Flash Bootloading issue

Hi,

The skipping the IDCODE may work only when the architecture of the selected flash matches with the architecture of the flash on board. Having said this, the programming or configuration operations may not be success even when the skip id code is done becuase Xilinx didn't test the flash.

Did you perform verify/readback tests on the flash after programming?

Can you please read the device status from impact after the configuration failure and share the log with me? This gives a hint on why the device configuration fails.

Regards,
Krishna
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos