UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer mroberto
Observer
7,044 Views
Registered: ‎08-09-2012

iMPACT crashes when a FTDI hardware is plugged to USB

Hi,

 

It took me some time to figure this out, but whenever I have a FTDI device (e.g. USB to RS-232 cable) connected to my computer, iMPACT crashes when I do a cable auto-connect or initialize chain.

 

When I start ISE and then iMPACT in a terminal, here is a copy of the terminal output:

INFO:iMPACT - Selected Current Working Directory:
'/home/myuser/xilinx/myproj'
libusb couldn't open USB device /dev/bus/usb/001/003: Permission denied.
libusb requires write access to USB device nodes.

 

Removing all FTDI based USB devices fixes the issue, iMPACT is able to find the Platform Cable USB II and program the device successfully.

 

I am using linux here, but I got a similar feedback from a windows user, though I can't confirm that myself.

 

Seems like a bug to me.

 

Best regards,

Marcelo.

 

0 Kudos
4 Replies
Instructor
Instructor
7,042 Views
Registered: ‎07-21-2009

Re: iMPACT crashes when a FTDI hardware is plugged to USB

I have two FTDI USB-serial bridge devices connected and operating, concurrently with iMPACT and Xilinx Platform Cable USB connected and operating (including "auto-connect" and initialise chain).  No problems.

 

I'm running Win Vista x64, ISE 13.4 and 14.1.  According to Device Manager:

  • FTDI driver version 2.8.14.0, dated 18-march-2011
  • Jungo WinDriver version 10.2.1.0, dated 31-aug-2010

Sorry, I cannot duplicate your results.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Observer mroberto
Observer
7,034 Views
Registered: ‎08-09-2012

Re: iMPACT crashes when a FTDI hardware is plugged to USB

Hi Bob,

 

Thanks for the quick reply.

 

On Linux we don't use the Jungo WinDriver, it does not compile on the installation process.

 

Is there any chance that someone test it on a Linux distribution? I am running OpenSUSE 12.1 here.

 

I think that the relevant software in this case is libusb, I believe it is what iMPACT is using to access the cable:

 

rpm -qa | grep libusb
libusb-1_0-0-1.0.8-9.1.2.x86_64
libusbmuxd1-1.0.7-6.4.1.x86_64
libusb-compat-devel-0.1.3-14.1.2.x86_64
libusb-1_0-devel-1.0.8-9.1.2.x86_64
libusb-1_0-0-32bit-1.0.8-9.1.2.x86_64
libusb-1_0-devel-32bit-1.0.8-9.1.2.x86_64
libusb-0_1-4-32bit-0.1.13-14.1.2.x86_64
libusb-0_1-4-0.1.13-14.1.2.x86_64

 

Best regards,

Marcelo.

 

0 Kudos
Highlighted
Visitor davidgander
Visitor
6,055 Views
Registered: ‎04-06-2010

Re: iMPACT crashes when a FTDI hardware is plugged to USB

I've got exactly the same behaviour, I'm using the following:
 
Ubuntu 12.04 (32 bit)
Xilinx ISE 14.3 (Impact 14.3/P.40xd)
Platform Cable USB II
 
While an FTDI USB->Serial Converter (on a devboard) is plugged in I get the same error and Impact crashes.
The VID/PID of the usb->serial converter is 0403:6001
 

Interestingly /var/log/syslog reports the following after the crash:
 
_impact4[3393]: segfault at 1c ip b0fd8b40 sp b0a2f830 error 4 in libftd2xx.so.1.0.4[b0fd1000+23000]
 
Which is a library found in multiple places under the Xilinx install directory and /usr/local/lib/
 
Dave

0 Kudos
Explorer
Explorer
5,728 Views
Registered: ‎11-21-2013

Re: iMPACT crashes when a FTDI hardware is plugged to USB

Hi, sorry to bother!

 

I was searching iMPACT cannot find JTAG Cable, and I saw this, and seems like you got it work on OpenSuse12.1,

 

Therefore I would like to ask for a favor.

 

I currently installed XILINX 14.4 on Opensuse12.3, and I got a Zedboard, I am struggled with different settings for two weeks (too long I know), and now I am still not working.

 

when use lsusb: I got

:/dev/bus/usb/003> lsusb -D /dev/bus/usb/003/004
Device: ID 0403:6014 Future Technology Devices International, Ltd FT232H Single HS USB-UART/FIFO IC
idVendor 0x0403 Future Technology Devices International, Ltd
idProduct 0x6014 FT232H Single HS USB-UART/FIFO IC
bcdDevice 9.00
iManufacturer 1 Digilent
iProduct 2 Digilent USB Device
iSerial 3 210248446648
bNumConfigurations 1

 

when 

> djtgcfg enum
Found 1 device(s)

Device: Zed
Product Name: Digilent Zed
User Name: Zed
Serial Number: 210248446648

 

But when xmd -> cannot found any Jtag cable

and when impact -> cannot found Jtag cable

 

I cannot succeed in installing windrvr6, so there's no windrvr6 under /dev

 

after I export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/../../libusb.so

 

impact shows:

 

cannot connect to /dev/parport0

...

cannot connect to /dev/parport1

 

I would be so appreciate if you have any ideas?

 

Thank you very much!

 

 

 

 

 

0 Kudos