UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
10,020 Views
Registered: ‎11-27-2014

unable to programme the spartan 3A device

Dear sir,

 

I am using Spartan 3A DSP xilinx FPGA, Device XC3SD1800A-FGG676AgQ1313 and it is configuring using a master serial mode using a XCF08P. But when I am going to download simple programme , I found that in JTAG chain only one device (xc3sd1800a) is present and XCF08P is missing.  But when I am going to dounload the program in the xc3sd1800a I am founding the programme failed message and cannot download it. The details message are attached here with. Please give me the solution. Thanking You.

 

With Regards

Pallab Kumar Nath

PhD student at IIT Kharagpur.

09830552910

 

//------------------------------------------------------------------------

// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
GUI --- Auto connect to cable...
// *** BATCH CMD : setCable -port auto
AutoDetecting cable. Please wait.
PROGRESS_START - Starting Operation.
Connecting to cable (Parallel Port - LPT1).
Checking cable driver.
Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Parallel Port - LPT2).
Checking cable driver.
Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Parallel Port - LPT3).
Checking cable driver.
Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Parallel Port - LPT4).
Checking cable driver.
Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Cable connection failed.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
Driver file xusb_emb.sys found.
Driver version: src=1029, dest=1029.
Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Cable PID = 0008.
Max current requested during enumeration is 300 mA.
Type = 0x0005.
write (count, cmdBuffer, dataBuffer) failed C0000004.
Cable Type = 3, Revision = 0.
Setting cable speed to 6 MHz.
Cable connection established.
Firmware version = 2301.
File version of C:/Xilinx10.1/10.1/ISE/data/xusb_xp2.hex = 2400.
Firmware hex file version = 2400.
Downloading C:/Xilinx10.1/10.1/ISE/data/xusb_xp2.hex.
Downloaded firmware version = 2400.
Type = 0x0005.
ESN option: 00001631BCE401.
PLD file version = 2007h.
PLD version = 200Dh.
PROGRESS_END - End Operation.
Elapsed time = 2 sec.
Attempting to identify devices in the boundary-scan chain configuration...// *** BATCH CMD : Identify
PROGRESS_START - Starting Operation.
Identifying chain contents ....'1': : Manufacturer's ID =Xilinx xc3sd1800a, Version : 0
INFO:iMPACT:1777 -
Reading C:/Xilinx10.1/10.1/ISE/spartan3adsp/data/xc3sd1800a.bsd...
INFO:iMPACT:501 - '1': Added Device xc3sd1800a successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
done.
PROGRESS_END - End Operation.
Elapsed time = 1 sec.
// *** BATCH CMD : identifyMPM
// *** BATCH CMD : assignFile -p 1 -file "E:/cntr/cntr.bit"
'1': Loading file 'E:/cntr/cntr.bit' ...
done.
INFO:iMPACT:2257 - Startup Clock has been changed to 'JtagClk' in the bitstream stored in memory,
but the original bitstream file remains unchanged.
INFO:iMPACT:501 - '1': Added Device xc3sd1800a successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
// *** BATCH CMD : Program -p 1
INFO:iMPACT:583 - '1': The idcode read from the device does not match the idcode in the bsdl File.
INFO:iMPACT:1578 - '1': Device IDCODE : 00001111111111111111111111111110
INFO:iMPACT:1579 - '1': Expected IDCODE: 00000011100001000000000010010011
PROGRESS_END - End Operation.
Elapsed time = 0 sec.
PROGRESS_START - Starting Operation.

0 Kudos
4 Replies
Community Manager
Community Manager
10,013 Views
Registered: ‎07-23-2012

Re: unable to programme the spartan 3A device

Hi,

Please reduce the cable speed and see if it helps in resolving the issue.

You can also try a different JTAG cable to see if the JTAG cable has got damaged.

Regards,
Krishna
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos
Xilinx Employee
Xilinx Employee
10,009 Views
Registered: ‎10-24-2013

Re: unable to programme the spartan 3A device

Hi,
Moving to correct board.
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
9,994 Views
Registered: ‎08-01-2012

Re: unable to programme the spartan 3A device

The log file is showing the IDCODE mismatching.  

 

The following Answer http://www.xilinx.com/support/answers/13529.html address the issues related to IDCODE mismatch. 

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
Moderator
Moderator
9,975 Views
Registered: ‎01-15-2008

Re: unable to programme the spartan 3A device

I see from the log file that you are using 10.1 impact, can you switch to 14.7 impact and see if this helps.

 

--Krishna

0 Kudos