UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor haozheng
Visitor
3,293 Views
Registered: ‎05-15-2015

CSIM problem

I keep encountering the problem with CSIM in Vivado HLS 2016.4. The error message is shown below. It says not rules to make Box.o, but there is no such file used in my examples. I tried an example of my own and the fir example from the tutorial, same problem happens for the C simulation.

 

Can anyone tell me what is going on? I tried HLS 2016 too, same the problem.

 

Thanks

 

- HZ

 

Starting C simulation ...
C:/Xilinx/Vivado_HLS/2016.4/bin/vivado_hls.bat C:/Users/Cathy/fir/solution1/csim.tcl
INFO: [HLS 200-10] Running 'C:/Xilinx/Vivado_HLS/2016.4/bin/unwrapped/win64.o/vivado_hls.exe'
INFO: [HLS 200-10] For user 'Cathy' on host 'lenovo-pc' (Windows NT_amd64 version 6.2) on Thu Apr 06 17:57:03 -0400 2017
INFO: [HLS 200-10] In directory 'C:/Users/Cathy'
INFO: [HLS 200-10] Opening project 'C:/Users/Cathy/fir'.
INFO: [HLS 200-10] Opening solution 'C:/Users/Cathy/fir/solution1'.
INFO: [SYN 201-201] Setting up clock 'default' with a period of 10ns.
INFO: [HLS 200-10] Setting target device to 'xcku035-sfva784-1-c'
INFO: [SIM 211-2] *************** CSIM start ***************
WARNING: [SIM 211-51] HLS only supports CLANG compiler in Linux.
INFO: [SIM 211-4] CSIM will launch GCC as the compiler.
make: *** No rule to make target `obj/Box.o', needed by `csim.exe'.  Stop.
ERROR: [SIM 211-100] 'csim_design' failed: compilation error(s).
INFO: [SIM 211-3] *************** CSIM finish ***************
4
    while executing
"source C:/Users/Cathy/fir/solution1/csim.tcl"
    invoked from within
"hls::main C:/Users/Cathy/fir/solution1/csim.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 hls::main {*}$args"
    (procedure "hls_proc" line 5)
    invoked from within
"hls_proc $argv"
Finished C simulation.

0 Kudos
2 Replies
Teacher muzaffer
Teacher
3,227 Views
Registered: ‎03-31-2012

Re: CSIM problem

@haozheng do you have a file called Box.x where x is any file extension? Also show your makefile to see how the csim.exe needs Box.o. The problem is that Box.o doesn't exist so it needs to be generated by Makefile but there is no rule for it. You need to understand how the Makefile is forcing make to try to make it.

- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
0 Kudos
Visitor jesusb
Visitor
1,272 Views
Registered: ‎05-31-2010

Re: CSIM problem

Hi,

 

Even though this message might come a little bit late, just for the record.

 

I've just learned that, when you upgrade to Ubuntu 18.04, the process puts everything upside down. So, as it happened to me, @muzaffer, so many packages went away after the installation of the new Ubuntu version.

 

The error you mentioned, it is caused either because gcc/g++ or make tools are missing. I am going to proceed with a thorough checking of the pre-conditions in my system for Vivado software so that no more "hidden" surprises make me fool around and waste my time.

 

Hope this post helps to other people.

 

Regards,

 

Jesús

0 Kudos