UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor rch1
Visitor
114 Views
Registered: ‎07-05-2018

Change compiler in Vivado HLS

Hello,

I am compiling pretty big project, but the project cannot be compiled with gcc 6.2.0 (the project is compiled with this version),  and I do now know how to change compiler to something different.

Log:

INFO: [SIM 211-2] *************** CSIM start ***************
INFO: [SIM 211-4] CSIM will launch GCC as the compiler.
Compiling ../../../../firmware/mnist_hls.cpp in debug mode
csim.mk:85: recipe for target 'obj/mnist_hls.o' failed
gcc: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [obj/mnist_hls.o] Error 4

 

Tags (2)
0 Kudos
1 Reply
Moderator
Moderator
63 Views
Registered: ‎05-31-2017

Re: Change compiler in Vivado HLS

HI @rch1 ,

Starting from Vivado HLS 2018.2, you will only be able to use gcc compiler. The CLANG option has been removed.

If you want to use the CLANG compiler then please use the earlier HLS versions. The equivalent command to use the clang compiler for C Simulation is "csim_design -compiler clang"

0 Kudos