UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Change DIFF_TERM property of IOBUFDS buffer from Tcl

Accepted Solution Solved
Highlighted
Observer
Posts: 50
Registered: ‎12-28-2011
Accepted Solution

Change DIFF_TERM property of IOBUFDS buffer from Tcl

Hi,

 

using an existing placed & routed design checkpoint, is it possible to modify the DIFF_TERM property of an IOBUFDS buffer using Tcl?

 

Trying to do this using the following command:

 

set_property  "DIFF_TERM" 0 [get_cells i_flwc_iobufds_0]

 

gives this error:

 

ERROR: [Netlist 29-75] Setting 'DIFF_TERM' property on 'cell' objects from input source 'TCL' is not supported.

 

Do I really have to re-implement the whole design if I need to change just that setting?

 

Thanks,

Guy.


Accepted Solutions
Moderator
Posts: 1,582
Registered: ‎01-16-2013

Re: Change DIFF_TERM property of IOBUFDS buffer from Tcl

[ Edited ]

@geschema1,

 

I believe the application object should be on ports but not a cell. Please check page 176 in below UG:

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2017_2/ug912-vivado-properties.pdf

 

Do I really have to re-implement the whole design if I need to change just that setting?

No need to re-implement the design.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
---------------------------------------------------------------------------------------------

View solution in original post


All Replies
Moderator
Posts: 1,582
Registered: ‎01-16-2013

Re: Change DIFF_TERM property of IOBUFDS buffer from Tcl

[ Edited ]

@geschema1,

 

I believe the application object should be on ports but not a cell. Please check page 176 in below UG:

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2017_2/ug912-vivado-properties.pdf

 

Do I really have to re-implement the whole design if I need to change just that setting?

No need to re-implement the design.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
---------------------------------------------------------------------------------------------
Observer
Posts: 50
Registered: ‎12-28-2011

Re: Change DIFF_TERM property of IOBUFDS buffer from Tcl

Thanks @syedz, it works as expected. The trick is to not set the property of the IOBUFDS buffer, but of the port it connects to:

 

set_property  "DIFF_TERM" 0 [get_ports FlowCtrl1_P]