UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor farnoodmb
Visitor
319 Views
Registered: ‎01-02-2019

Failed to get a license for 'xczu7ev-es2' for ZCU104 board when sourcing .tcl file in Vivado

Hi all,

I am trying to rebuild the overlay of the ZCU104 board in vivado using:

cd <PYNQ repository>/boards/ZCU104/base
source ./build_base_ip.tcl
source ./base.tcl

 but I am getting the following error when running te second command in Vivado Tcl console:

WARNING: [Common 17-301] Failed to get a license for 'xczu7ev-es2'. Explanation: The license feature xczu7ev-es2 could not be found.
Resolution: Check the status of your licenses in the Vivado License Manager. For debug help search Xilinx Support for "Licensing FAQ".
command 'ap_source' returned error code
while executing
"source [lindex $::argv 1] "
("uplevel" body line 1)
invoked from within
"uplevel \#0 { source [lindex $::argv 1] } "

INFO: [Common 17-206] Exiting vivado_hls at Mon Jan 28 17:06:58 2019...
ERROR: [HLS 200-70] License checkout unsuccessful. Make sure that a license is accessible or specify an appropriate one through an environment variable.

I have purchased the board directly from Xilinx and have the Vivado HLx edition 2018.3. I got the free license from the Product Licensing website from Xilinx. On the website, it is mentioned that with the purchase of the board, I will receive the Vivado Design Suite Design Edition locked for the node. But the lisence I received for free is for HL Webpack 2015 and earlier. Am I missing something or do I need a vochour to get the license for the board?

I am new to these board so any suggestion is appreciated.

Thanks,

Fred

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
290 Views
Registered: ‎05-22-2018

Re: Failed to get a license for 'xczu7ev-es2' for ZCU104 board when sourcing .tcl file in Vivado

Hi @farnoodmb,

I think the issue is might be because of enbaling Beta Devices.

Please try this command enable_beta_device* through TCL console.

Hope the provided information will be helpful.

Regards,

Raj Singh.

0 Kudos
Visitor farnoodmb
Visitor
237 Views
Registered: ‎01-02-2019

Re: Failed to get a license for 'xczu7ev-es2' for ZCU104 board when sourcing .tcl file in Vivado

Thanks Raj for a quick reply. 

When I run that command, I get the following:

0 Beta devices matching pattern found, 0 enabled.

Among the licenses, I have the "xczu7ev" as a locked node, but not the "xczu7ev-es2". 

I am not sure but there was suggestions to get the license by requesting it from

UltraScale Architecture Early Access Errata Lounge

I have just sent the request and waiting for the reply. Should I be able to get the  "xczu7ev-es2" license from there?

Thanks,

Farnood

0 Kudos
Moderator
Moderator
210 Views
Registered: ‎03-16-2017

Re: Failed to get a license for 'xczu7ev-es2' for ZCU104 board when sourcing .tcl file in Vivado

Hi @farnoodmb,

I do not see any ES2 device for xczu7ev part in Vivado 2018.3. But 2018.2 and 2018.1 has it.

Provide full part name for xczu7ev. 

>>Should I be able to get the  "xczu7ev-es2" license from there?

Not sure.

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos