cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous
Not applicable
15,149 Views

How to disable backup .log and .jou files?

Hello,

 

I have looked through the documentation for a property, parameter, or command line option  which will disable the creation of backup files for .jou and .log. I do see from the command line help that there are options to disable and/or append to pre-existing ones, but nothing to disable the backup files.

 

  [-nojournal]   Do not create a journal file
  [-appjournal]  Open journal file in append mode
  [-journal]     Journal file name
  [-nolog]       Do not create a log file
  [-applog]      Open log file in append mode
  [-log]         Log file name

Thanks in advance,

George

0 Kudos
Reply
5 Replies
vuppala
Xilinx Employee
Xilinx Employee
15,146 Views
Registered: ‎04-16-2012

Hi,

 

I tried with options -nojournal and -nolog and it worked.. I opened ISE Command Prompt 14.2 and ran the command below:

 

C:\Xilinx\14.2\ISE_DS>cd\

C:\> cd example_tcl

C:\example_tcl> vivado -nojournal -nolog

 

It worked and I didnt see any .jou and .log files  generated in the folder example_tcl.

 

Thanks.

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Reply
Anonymous
Not applicable
15,134 Views

In the original question, I believe I'm asking how to disable the creation of backup files, not the files themselves. The default behavior of the tool keeps all .log and .jou files, and I'm looking (in linux) for overwrite.

 

-rw-r--r-- 1 eng    425 Jan 16 13:17 ../viv2/vivado_57431.backup.jou
-rw-r--r-- 1 eng    431 Jan 16 18:24 ../viv2/vivado_63014.backup.jou
-rw-r--r-- 1 eng    418 Jan 16 18:27 ../viv2/vivado_5643.backup.jou
-rw-r--r-- 1 eng    417 Jan 16 19:58 ../viv2/vivado_6338.backup.jou

Thanks,

George

0 Kudos
Reply
duthv
Xilinx Employee
Xilinx Employee
15,124 Views
Registered: ‎09-14-2007

Hi George,

 

You can set the following param in your init.tcl file:

 

set_param general.maxBackupLogs 0
 
You can also change this number to what ever number suites your taste too.
 
We talk about the init.tcl file in the Tcl scripting UG:
 
Thanks
Duth
0 Kudos
Reply
mikef.pentek
Visitor
Visitor
9,384 Views
Registered: ‎07-21-2015

Which init file? I have more then 10 init.tcl files in my C:\Xilinx\Vivado\2016.1 sub directories. 

 

Capture.PNG
0 Kudos
Reply
duthv
Xilinx Employee
Xilinx Employee
9,380 Views
Registered: ‎09-14-2007

Hi,


The document I pointed to covers this:

 

Loading and Running Tcl Scripts The Vivado Design Suite offers several different ways to load and run a Tcl script during a design session. You can have script files loaded automatically when the tool is launched, source scripts from the Tcl command line, or add them to the menus in the Vivado IDE. Initializing Tcl Scripts The Vivado Design Suite can automatically load Tcl scripts defined in an init.tcl file. This approach is useful when you have written Tcl procedures that define new commands that you want to make available in all your Vivado sessions. When you start the Vivado tool, it looks for a Tcl initialization script in two different locations: 1. In the software installation: /Vivado/version/scripts/init.tcl 2. In the local user directory: a. For Windows 7: %APPDATA%/Roaming/Xilinx/Vivado/init.tcl b. For Linux: $HOME/.Xilinx/Vivado/init.tcl Where is the installation directory where the Vivado Design Suite is installed

 

Thanks
Duth

 

0 Kudos
Reply