cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
andrei_militaru
Visitor
Visitor
7,086 Views
Registered: ‎11-28-2018

Vivado 2019.1 installation on Ubuntu 19.04

Jump to solution

Hi everybody,

I have recently tried to download the Vivado Design Suite 2019.1 for Ubuntu 19.04. I think the specific version of Vivado that I am aiming at is not really the point here, as the same happened with Vivado 2017.2 as well.

I correctly download the Linux installer and I run the installing script from terminal (no sudo).

Once the installation is done, I move to the folder where the installed files are stored and I try to run the script settings64.sh. Once this is done, I move to the bin folder and run ./vivado, however I get an error that goes like this:

application-specific initialization failed: couldn't load file "librdi_commontasks.so": libtinfo.so.5: cannot open shared object file: No such file or directory

The librdi_commontasks.so shared library is actually inside the Vivado folder as well, so it does exist but Vivado is not able to find it.

It seems to me that some definitions of paths and directories to be checked goes wrong during some of the installations steps, but I do not know where and what so it is not possible for me to correct it.

 

Has anyone experienced some similar problem and found a solution for it? Any help is much appreciated, thank you.

0 Kudos
1 Solution

Accepted Solutions
hongh
Moderator
Moderator
7,074 Views
Registered: ‎11-04-2010

Hi, @andrei_militaru ,

Ubuntu 19.04 is not a supported Operating System and please use the supported OS to install vivado.

Supported Ubuntu Version:  Ubuntu Linux 16.04.5, 18.04.1 LTS (64-bit)

You can refer to UG973 to get all the supported Operating system for Vivado 2019.1

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

4 Replies
hongh
Moderator
Moderator
7,075 Views
Registered: ‎11-04-2010

Hi, @andrei_militaru ,

Ubuntu 19.04 is not a supported Operating System and please use the supported OS to install vivado.

Supported Ubuntu Version:  Ubuntu Linux 16.04.5, 18.04.1 LTS (64-bit)

You can refer to UG973 to get all the supported Operating system for Vivado 2019.1

 

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

andrei_militaru
Visitor
Visitor
7,050 Views
Registered: ‎11-28-2018

Indeed, this seems to have been the problem. I though that it would have worked the same, but it was not the case.

I am now running it on Ubuntu 18.04.2 LTS, it seems to be working fine on this version even though it is supposed to be compatible only with 18.04.1 LTS.

0 Kudos
6,208 Views
Registered: ‎11-12-2019

The program launches if you install libtinfo5:

apt install libtinfo5
joeblue
Visitor
Visitor
3,642 Views
Registered: ‎04-27-2020
thanks! this did the trick... (using Ubuntu 19.10 and Vivado 2019.2 here)
0 Kudos